<!doctype html><html lang="en" dir="ltr"><head><meta http-equiv="X-UA-Compatible" content="IE=EDGE"/><meta http-equiv="cache-control" content="max-age=0"/><meta http-equiv="cache-control" content="no-cache"/><meta http-equiv="expires" content="0"/><meta http-equiv="expires" content="Tue, 01 Jan 1980 1:00:00 GMT"/><meta http-equiv="pragma" content="no-cache"/><script>window.buildTime = 1653583127335</script><meta property="APP_NAME" content="app-blog"><meta property="VER" content="fc96cc3dc"><meta charset="UTF-8"/><script id="styleFonts" style="display:none" type="application/ld+json">"
 
    @font-face {
      font-display: fallback;
      font-family: Proxima_Nova;
      font-weight: 400;
      src: url(https://tr-frontend-cdn.azureedge.net/static/v1/static/fonts/normal/font.woff);
    }
 
    @font-face {
      font-display: fallback;
      font-family: Proxima_Nova;
      font-weight: 600;
      src: url(https://tr-frontend-cdn.azureedge.net/static/v1/static/fonts/semibold/font.woff);
    }
 
    @font-face {
      font-display: fallback;
      font-family: Proxima_Nova;
      font-weight: 700;
      src: url(https://tr-frontend-cdn.azureedge.net/static/v1/static/fonts/bold/font.woff);
    }
 
    @font-face {
      font-display: fallback;
      font-family: Proxima_Nova;
      font-weight: 700;
      src: url(https://tr-frontend-cdn.azureedge.net/static/v1/static/fonts/bold/font.woff2);
    }
 
    @font-face {
      font-display: fallback;
      font-family: Proxima_Nova;
      font-weight: 900;
      src: url(https://tr-frontend-cdn.azureedge.net/static/v1/static/fonts/bolder/font.woff);
    }
 
    @font-face {
      font-display: fallback;
      font-family: Proxima_Nova;
      font-weight: 900;
      src: url(https://tr-frontend-cdn.azureedge.net/static/v1/static/fonts/bolder/font.woff2);
    }
 
    @font-face {
      font-display: fallback;
      font-family: Proxima_Nova_regular;
      font-weight: 400;
      src: url(https://tr-frontend-cdn.azureedge.net/static/v1/static/fonts/regular_normal/font.woff);
    }
 
    @font-face {
      font-display: fallback;
      font-family: Proxima_Nova_regular;
      font-weight: 600;
      src: url(https://tr-frontend-cdn.azureedge.net/static/v1/static/fonts/regular_semibold/font.woff);
    }
 
    @font-face {
      font-display: fallback;
      font-family: Proxima_Nova_regular;
      font-weight: 600;
      src: url(https://tr-frontend-cdn.azureedge.net/static/v1/static/fonts/regular_semibold/font.woff2);
    }
 
    @font-face {
      font-display: fallback;
      font-family: Proxima_Nova_regular;
      font-weight: 700;
      src: url(https://tr-frontend-cdn.azureedge.net/static/v1/static/fonts/regular_bold/font.woff);
    }
 
    @font-face {
      font-display: fallback;
      font-family: Proxima_Nova_regular_condensed;
      font-weight: 400;
      src: url(https://tr-frontend-cdn.azureedge.net/static/v1/static/fonts/regular_condensed__normal/font.woff);
    }
 
    @font-face {
      font-display: fallback;
      font-family: Proxima_Nova_regular_condensed;
      font-weight: 400;
      src: url(https://tr-frontend-cdn.azureedge.net/static/v1/static/fonts/regular_condensed__normal/font.woff2);
    }
 
    @font-face {
      font-display: fallback;
      font-family: Proxima_Nova_condensed;
      font-weight: 600;
      src: url(https://tr-frontend-cdn.azureedge.net/static/v1/static/fonts/condensed_semibold/font.woff);
    }
 
    @font-face {
      font-display: fallback;
      font-family: Proxima_Nova_condensed;
      font-weight: 600;
      src: url(https://tr-frontend-cdn.azureedge.net/static/v1/static/fonts/condensed_semibold/font.woff2);
    }
 
    @font-face {
      font-display: fallback;
      font-family: Proxima_Nova_condensed;
      font-weight: 700;
      src: url(https://tr-frontend-cdn.azureedge.net/static/v1/static/fonts/condensed_bold/font.woff);
    }
 "</script><style>#bs-fraud-sid {
      position: absolute;
      top: 0;
    }</style><meta name="viewport" content="width=device-width,initial-scale=1,user-scalable=no"/><script>function loadScriptTag(src, attr) {
          var head = document.getElementsByTagName("head")[0];
          var script = document.createElement("script");
          if (attr) {
            for (var k in attr) {
              script.setAttribute(k, attr[k]);
            }
          }
          script.src = src;
          head.appendChild(script);
    }

  // ==============

  function loadFonts(){
        var isFontLoaded = document.getElementById("font-style");
        if(isFontLoaded)return;
        var style = document.createElement('style');
        style.id="font-style"
        style.innerHTML = document.getElementById("styleFonts").textContent;
        document.head.appendChild(style);
        localStorage.setItem("font-loaded",true)
      }
      try{
        if(localStorage.getItem("font-loaded")){
          loadFonts();
        }
      }catch(e){
         
      }
  //============
    function getCookie() {
      return document.cookie
        .split("; ")
        .map(function (x) {
          return x.split("=");
        })
        .filter(function (x) {
          return x;
        })
        .reduce(function (a, n) {
          a[n[0]] = n[1];
          return a;
        }, {});
    }
    function parseQuery() {
      var queryString= window.location.search;
      if(!queryString)return {}
      var query = {};
      var pairs = (queryString[0] === '?' ? queryString.substr(1) : queryString).split('&');
      for (var i = 0; i < pairs.length; i++) {
          var pair = pairs[i].split('=');
          query[decodeURIComponent(pair[0])] = decodeURIComponent(pair[1] || '');
      }
      return query;
  }
   
    try {
      window.__tipranksPlanId__= (function(){
        var trUserID = getCookie()["tr-plan-id"];
        if(!trUserID){
          var str = localStorage.getItem("user");
          if (str) {
            var data = JSON.parse(str);
            trUserID = data && data.planId;
          }
        }
          if(trUserID){
           return  {
                "0": "open",
                "1": "basic",
                "2": "beta",
                "3": "premium",
                "4": "ultimate",
                "6": "premium",
                "5": "ultimate"
              }[trUserID];
          } 
      })()
    } catch (e) {
      console.log(e)
    }</script><link href="https://tr-frontend-cdn.azureedge.net/blog/__tr__/prod/css/1a8412edc99b0beeb455.styles.css" rel="preload" as="style"/><meta name="theme-color" content="#121212" /><link rel="manifest" href="https://tr-frontend-cdn.azureedge.net/blog/__tr__/prod/manifest.json" />
  
  
<title data-react-helmet="true">Why Did ChargePoint Stock Decline on Tuesday?</title>
<meta data-react-helmet="true" property="og:title" content="Why Did ChargePoint Stock Decline on Tuesday?"/><meta data-react-helmet="true" property="twitter:title" content="Why Did ChargePoint Stock Decline on Tuesday?"/><meta data-react-helmet="true" property="og:url" content="https://www.tipranks.com/news/why-did-chargepoint-stock-decline-on-tuesday/"/><meta data-react-helmet="true" name="twitter:image" content="https://blog.tipranks.com/wp-content/uploads/2022/06/shutterstock_1932544553-750x406.jpg"/><meta data-react-helmet="true" property="og:image" content="https://blog.tipranks.com/wp-content/uploads/2022/06/shutterstock_1932544553-750x406.jpg"/><meta data-react-helmet="true" property="og:description" content="ChargePoint Holdings, Inc. (NYSE: CHPT) disappointed investors after reporting dismal bottom-line results for the first quarter of Fiscal 2023 (ended April 30, 2022..."/><meta data-react-helmet="true" property="twitter:description" content="ChargePoint Holdings, Inc. (NYSE: CHPT) disappointed investors after reporting dismal bottom-line results for the first quarter of Fiscal 2023 (ended April 30, 2022..."/><meta data-react-helmet="true" name="description" content="ChargePoint Holdings, Inc. (NYSE: CHPT) disappointed investors after reporting dismal bottom-line results for the first quarter of Fiscal 2023 (ended April 30, 2022..."/><meta data-react-helmet="true" name="twitter:card" content="summary_large_image"/><meta data-react-helmet="true" property="og:app_id" content="832022363549366"/><meta data-react-helmet="true" property="og:locale" content="en_US"/><meta data-react-helmet="true" property="og:site_name" content="TipRanks Financial"/><meta data-react-helmet="true" property="og:type" content="article"/><meta data-react-helmet="true" property="article:author" content="https://www.tipranks.com/news/author/payalchhawchharia"/><meta data-react-helmet="true" property="article:section" content="Market News"/><meta data-react-helmet="true" property="article:updated_time" content="2022-06-01T13:59:09.000Z"/>
<link data-react-helmet="true" rel="icon" type="image/png" href="https://tr-frontend-cdn.azureedge.net/static/v1/static/images/logo/tipranks/favicon.ico"/><link data-react-helmet="true" rel="canonical" href="https://www.tipranks.com/news/why-did-chargepoint-stock-decline-on-tuesday/"/>
<meta property="update_time" content="2022-06-01T14:12:21.165Z">
<meta property="maker" content="CRON">
<meta property="variant" content="desktop">
  
           <meta name="apple-itunes-app" content="app-id=1237516490, app-argument=myURL">

  <link rel="preload" href="/news/data/sideBar/payload.json?ver=1654092741165" as="fetch" crossorigin="anonymous">
  <style>

    #tr-blog-main-post{
      height: 615px;
    }

    @media screen and (max-width: 1090px) {
      #tr-blog-main-post{
        height: 615px;
      }
    }
  
    @media screen and (max-width: 868px) {
      #tr-blog-main-post{
        height: 480px;
      }
    }

    @media screen and (max-width: 560px) {
      #tr-blog-main-post{
        height: 265px;
      }
    }

  </style>

           <style>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</style></head><body class="tr-app tr-loading"><script>if (window.__tipranksPlanId__ !== undefined)
       document.body.className += " tr-body-" + window.__tipranksPlanId__;
    var cookieData=getCookie();
    if(cookieData.hadHoldings){
       document.body.className += " tr-body-had_holding"
    }

     if(cookieData.user){
       document.body.className += " tr-body-loggedin"
    }else{
       document.body.className += " tr-body-notLoggedIn tr-body-open"

    }

    if (cookieData.noTopRibbon) {
      document.body.className += " tr-body-noTopRibbon"
    }</script>
  <link rel="preload" href="https://tr-frontend-cdn.azureedge.net/blog/prod/news/why-did-chargepoint-stock-decline-on-tuesday/payload.json?ver=1654092741165" as="fetch" crossorigin="anonymous">
  <div id="root"><div class="displayblock minHscreen ipadpro_minHauto ipad_displayblock"><div class="_2Hp3GxrrrlaIFqRB8AChgQ   shadowheader"><div class="_3KzY-GPrx1UMo1N_vJ1jHS        displayflex" id="MainHeader"><div class="_3rFk6QFilyZfk2qzHGCMZJ        displayflex"><div class="flexrsc     displayflex grow1 mr4 ipad_mr0"><a data-link="tipranks" href="/"><img class="mr4 h_pxsmall35 displayflex flexrsc desktop_mr3 mobile_displaynone" src="https://tr-frontend-cdn.azureedge.net/static/v1/static/images/logo/tipranks/black-trust.svg" loading="lazy" alt="tipranks"/><img class="displaynone mobile_displayflex mobile_maxWparent mobile_h_pxsmall mobile_mr0" src="https://tr-frontend-cdn.azureedge.net/static/v1/static/images/logo/tipranks/black.svg" loading="lazy" alt="tipranks"/></a><div style="min-width:364px"></div><div class="_2k116AssGOzjmXhT_2TKme   flexrc_ w12    displayflex positionrelative z2 ipadpro_displaynone"><div class="_3Zmripick4FHmFICG_9P3V        displayflex"><div class="bgwhite flexc__     displayflex maxWscreen"><div class="flexrcc     displayflex positionrelative" data-id="header-top-menu"><div class="flexr__ fontSize6small positionrelative"><div class="flexccc     displayflex group childrenhide_first positionrelative"><div class="displaynone positionabsolute anchortop w_pxauto minW220 z2 ml0 pointerEventnone" style="top:40px;right:-450%"><div class="bgwhite      displayflex positionrelative shadow3 radiilarge pointerEventauto"><div class="displayflex py3"><div class="flexc__  p3   displayflex br1_solid borderColorwhite-1"><div class="displayflex"><i class="_2DCU1pNSEfcdXke828nLl3 icon-star-white    fontSize10 displayinline-flex  pr2 pt2 bgwhite"></i><span class="fontSize7 fontWeightsemibold    pb3">Top Stocks</span></div><div class="flexcssf pb3 w_px6"><a class="fontSize7 alignstart px2 py4 flexrsc w12 hoverColororange hoverBgwhite-2" data-link="research-tools_stocks-top-rated" href="/stocks/top-rated"><span>Top Analyst Stocks</span></a><a class="fontSize7 alignstart px2 py4 flexrsc w12 hoverColororange hoverBgwhite-2" data-link="research-tools_stocks-to-buy" href="/stocks-to-buy"><span>Top Smart Score Stocks</span></a><a class="fontSize7 alignstart px2 py4 flexrsc w12 hoverColororange hoverBgwhite-2" data-link="research-tools_insiders-hot-stocks" href="/experts/insiders/hot-stocks"><span>Top Insiders Stocks</span><div class="ml2 fontWeightnormal lineHeight3 radiiround fontSize12 px3 pt1 flexccc colorwhite bgorange">Popular</div></a><a class="fontSize7 alignstart px2 py4 flexrsc w12 hoverColororange hoverBgwhite-2" data-link="research-tools_screener-stocks" href="/screener/stocks"><span>Stock Screener</span></a><a class="fontSize7 alignstart px2 py4 flexrsc w12 hoverColororange hoverBgwhite-2" data-link="research-tools_web-traffic-screener" href="/screener/website-traffic/top-websites"><span>Top Online Growth Stocks</span><div class="ml2 fontWeightnormal lineHeight3 radiiround fontSize12 px3 pt1 flexccc colorwhite bgpale-dark">New</div></a><a class="fontSize7 alignstart px2 py4 flexrsc w12 hoverColororange hoverBgwhite-2" data-link="research-tools_trending-stocks" href="/trending-stocks"><span>Trending Stocks</span></a><a class="fontSize7 alignstart px2 py4 flexrsc w12 hoverColororange hoverBgwhite-2" data-link="research-tools_screener-slug" href="/screener/penny-stocks"><span>Penny Stock Screener</span></a></div></div><div class="flexc__  p3   displayflex br1_solid borderColorwhite-1"><div class="displayflex"><i class="_2DCU1pNSEfcdXke828nLl3 icon-coinStack    fontSize10 displayinline-flex  pr2 pt2 bgwhite"></i><span class="fontSize7 fontWeightsemibold    pb3">Dividend Investing</span></div><div class="flexcssf pb3 w_px6"><a class="fontSize7 alignstart px2 py4 flexrsc w12 hoverColororange hoverBgwhite-2" data-link="research-tools_dividend-calculator" href="/tools/dividend-calculator"><span>Dividend Calculator</span></a><a class="fontSize7 alignstart px2 py4 flexrsc w12 hoverColororange hoverBgwhite-2" data-link="research-tools_dividend-yield-calc" href="/tools/dividend-yield-calculator"><span>Dividend Yield Calculator</span><div class="ml2 fontWeightnormal lineHeight3 radiiround fontSize12 px3 pt1 flexccc colorwhite bgpale-dark">New</div></a><a class="fontSize7 alignstart px2 py4 flexrsc w12 hoverColororange hoverBgwhite-2" data-link="research-tools_compare-stocks-slug" href="/compare-stocks/dividend-stocks"><span>Dividend Stocks</span></a><a class="fontSize7 alignstart px2 py4 flexrsc w12 hoverColororange hoverBgwhite-2" data-link="research-tools_news-topic" href="/news/topic/dividend-stocks"><span>Dividend News</span></a></div></div><div class="flexc__  p3   displayflex br1_solid borderColorwhite-1"><div class="displayflex"><i class="_2DCU1pNSEfcdXke828nLl3 icon-balance    fontSize10 displayinline-flex  pr2 pt2 bgwhite"></i><span class="fontSize7 fontWeightsemibold    pb3">Stock Comparison</span></div><div class="flexcssf pb3 w_px6"><a class="fontSize7 alignstart px2 py4 flexrsc w12 hoverColororange hoverBgwhite-2" data-link="research-tools_compare-stocks-slug" href="/compare-stocks/nft"><span>NFT Stocks</span><div class="ml2 fontWeightnormal lineHeight3 radiiround fontSize12 px3 pt1 flexccc colorwhite bgorange">Popular</div></a><a class="fontSize7 alignstart px2 py4 flexrsc w12 hoverColororange hoverBgwhite-2" data-link="research-tools_compare-stocks-slug" href="/compare-stocks/oil-stocks"><span>Oil Stocks</span></a><a class="fontSize7 alignstart px2 py4 flexrsc w12 hoverColororange hoverBgwhite-2" data-link="research-tools_compare-stocks-slug" href="/compare-stocks/Value"><span>Best Value Stocks</span></a><a class="fontSize7 alignstart px2 py4 flexrsc w12 hoverColororange hoverBgwhite-2" data-link="research-tools_compare-stocks-slug" href="/compare-stocks/airline"><span>Airline Stocks</span></a><a class="fontSize7 alignstart px2 py4 flexrsc w12 hoverColororange hoverBgwhite-2" data-link="research-tools_compare-stocks-slug" href="/compare-stocks/electric-vehicles"><span>Electric Vehicle Stocks</span></a><a class="fontSize7 alignstart px2 py4 flexrsc w12 hoverColororange hoverBgwhite-2" data-link="research-tools_compare-stocks-slug" href="/compare-stocks/faang"><span>FAANG Stocks</span></a><a class="fontSize7 alignstart px2 py4 flexrsc w12 hoverColororange hoverBgwhite-2" data-link="research-tools_compare-stocks-slug" href="/compare-stocks/wallstreetbets"><span>WallStreetBets Stocks</span></a><a class="fontSize7 alignstart px2 py4 flexrsc w12 hoverColororange hoverBgwhite-2" data-link="research-tools_compare-stocks-slug" href="/compare-stocks/bank-stocks"><span>Bank Stocks</span></a><a class="fontSize7 alignstart px2 py4 flexrsc w12 hoverColororange hoverBgwhite-2" data-link="research-tools_compare-stocks" href="/compare-stocks"><span>Compare More Stocks…</span></a></div></div><div class="flexc__  p3   displayflex br1_solid borderColorwhite-1"><div class="displayflex"><i class="_2DCU1pNSEfcdXke828nLl3 icon-calander    fontSize10 displayinline-flex  pr2 pt2 bgwhite"></i><span class="fontSize7 fontWeightsemibold    pb3">Calendars</span></div><div class="flexcssf pb3 w_px6"><a class="fontSize7 alignstart px2 py4 flexrsc w12 hoverColororange hoverBgwhite-2" data-link="research-tools_calendars-ipo-pricing" href="/calendars/ipo/"><span>IPO Calendar</span></a><a class="fontSize7 alignstart px2 py4 flexrsc w12 hoverColororange hoverBgwhite-2" data-link="research-tools_calendars-earnings" href="/calendars/earnings/"><span>Earnings Calendar</span></a><a class="fontSize7 alignstart px2 py4 flexrsc w12 hoverColororange hoverBgwhite-2" data-link="research-tools_calendars-dividends" href="/calendars/dividends/"><span>Dividend Calendar</span></a><a class="fontSize7 alignstart px2 py4 flexrsc w12 hoverColororange hoverBgwhite-2" data-link="research-tools_calendars-economic" href="/calendars/economic"><span>Economic Calendar</span><div class="ml2 fontWeightnormal lineHeight3 radiiround fontSize12 px3 pt1 flexccc colorwhite bgpale-dark">New</div></a><a class="fontSize7 alignstart px2 py4 flexrsc w12 hoverColororange hoverBgwhite-2" data-link="research-tools_calendars-market-holidays" href="/calendars/market-holidays/"><span>Market Holidays</span></a><a class="fontSize7 alignstart px2 py4 flexrsc w12 hoverColororange hoverBgwhite-2" data-link="research-tools_stock-ratings" href="/stock-ratings"><span>Daily Analyst Ratings</span></a><a class="fontSize7 alignstart px2 py4 flexrsc w12 hoverColororange hoverBgwhite-2" data-link="research-tools_inside-trading" href="/inside-trading"><span>Daily Insider Trading</span></a></div></div></div></div></div><button class="colorgray-5 gHoverBgwhite-2 px3 h_px1 positionrelative borderColorgray fontWeightlight flexcec pb3 fontSize8 bginherit br1_solid brColortransparent bl1_solid blColortransparent radiilarge laptop_fontSize9 laptop_px2 laptop_mr2 wide_px4 wide_fontSize7" data-text="Research Tools" data-id="research-tools"><div>Research Tools <i class="_2DCU1pNSEfcdXke828nLl3 icon-back _1acbDrmILmOdyryPG9dqH0    fontSize12 displayinline-flex  mt3 pl2 laptop_fontSizesmaller"></i></div></button></div><div class="flexccc     displayflex group childrenhide_first positionrelative"><div class="displaynone positionabsolute anchortop w_pxauto minW220 z2 ml0 pointerEventnone" style="top:40px"><div class="bgwhite      displayflex positionrelative shadow3 radiilarge pointerEventauto"><div class="flexcss py3 w_pxauto minW280"><a class="activedisabled activecolororange  fontSize7 alignstart px4 py4 flexrsc minWparent hoverBgwhite-2 hoverColororange" data-link="top-experts-header_my-experts" href="/account/my-experts"><span>My Experts</span></a><a class="activedisabled activecolororange  fontSize7 alignstart px4 py4 flexrsc minWparent hoverBgwhite-2 hoverColororange" data-link="top-experts-header_experts-top" href="/experts/analysts/top"><span>Top Analysts</span></a><a class="activedisabled activecolororange  fontSize7 alignstart px4 py4 flexrsc minWparent hoverBgwhite-2 hoverColororange" data-link="top-experts-header_experts-top" href="/experts/bloggers/top"><span>Top Financial Bloggers</span></a><a class="activedisabled activecolororange  fontSize7 alignstart px4 py4 flexrsc minWparent hoverBgwhite-2 hoverColororange" data-link="top-experts-header_experts-top" href="/experts/insiders/top"><span>Top-Performing Corporate Insiders</span></a><a class="activedisabled activecolororange  fontSize7 alignstart px4 py4 flexrsc minWparent hoverBgwhite-2 hoverColororange" data-link="top-experts-header_experts-top" href="/experts/hedge-funds/top"><span>Top Hedge Fund Managers</span></a><a class="activedisabled activecolororange  fontSize7 alignstart px4 py4 flexrsc minWparent hoverBgwhite-2 hoverColororange" data-link="top-experts-header_firms-top" href="/firms/top"><span>Top Research Firms</span></a><a class="activedisabled activecolororange  fontSize7 alignstart px4 py4 flexrsc minWparent hoverBgwhite-2 hoverColororange" data-link="top-experts-header_experts-top" href="/experts/investors/top"><span>Top Individual Investors</span></a></div></div></div><button class="colorgray-5 gHoverBgwhite-2 px3 h_px1 positionrelative borderColorgray fontWeightlight flexcec pb3 fontSize8 bginherit br1_solid brColortransparent bl1_solid blColortransparent radiilarge laptop_fontSize9 laptop_px2 laptop_mr2 wide_px4 wide_fontSize7" data-text="Top Experts" data-id="top-experts-header"><div>Top Experts <i class="_2DCU1pNSEfcdXke828nLl3 icon-back _1acbDrmILmOdyryPG9dqH0    fontSize12 displayinline-flex  mt3 pl2 laptop_fontSizesmaller"></i></div></button></div><div class="flexccc     displayflex group childrenhide_first positionrelative"><div class="displaynone positionabsolute anchortop w_pxauto minW220 z2 ml0 pointerEventnone" style="top:40px"><div class="bgwhite      displayflex positionrelative shadow3 radiilarge pointerEventauto"><div class="flexcss py3 w_pxauto minW280"><a class="activedisabled activecolororange  fontSize7 alignstart px4 py4 flexrsc minWparent hoverBgwhite-2 hoverColororange" data-link="news_news" href="/news"><span>Market News</span></a><a class="activedisabled activecolororange  fontSize7 alignstart px4 py4 flexrsc minWparent hoverBgwhite-2 hoverColororange" data-link="news_news-category-article" href="/news/category/article"><span>Stock Analysis &amp; Ideas</span><div class="ml2 fontWeightnormal lineHeight3 radiiround fontSize12 px3 pt1 flexccc colorwhite bgorange">Popular</div></a><a class="activedisabled activecolororange  fontSize7 alignstart px4 py4 flexrsc minWparent hoverBgwhite-2 hoverColororange" data-link="news_news-topic" href="/news/topic/expert-spotlight"><span>Expert Spotlight</span></a><a class="activedisabled activecolororange  fontSize7 alignstart px4 py4 flexrsc minWparent hoverBgwhite-2 hoverColororange" data-link="news_news-category-labs" href="/news/category/labs"><span>Tipranks Labs</span></a><a class="activedisabled activecolororange  fontSize7 alignstart px4 py4 flexrsc minWparent hoverBgwhite-2 hoverColororange" data-link="news_news-topic" href="/news/topic/earnings-reports-insights"><span>Earnings Reports Insights</span></a><a class="activedisabled activecolororange  fontSize7 alignstart px4 py4 flexrsc minWparent hoverBgwhite-2 hoverColororange" data-link="news_news-topic" href="/news/topic/pre-market"><span>Pre-Market Breakdowns</span></a><a class="activedisabled activecolororange  fontSize7 alignstart px4 py4 flexrsc minWparent hoverBgwhite-2 hoverColororange" data-link="news_news-topic" href="/news/topic/dividend-stocks"><span>Dividend Stock News</span></a><a class="activedisabled activecolororange  fontSize7 alignstart px4 py4 flexrsc minWparent hoverBgwhite-2 hoverColororange" data-link="news_news-topic" href="/news/topic/crypto-stocks"><span>Crypto Stocks</span></a></div></div></div><button class="colorgray-5 gHoverBgwhite-2 px3 h_px1 positionrelative borderColorgray fontWeightlight flexcec pb3 fontSize8 bginherit br1_solid brColortransparent bl1_solid blColortransparent radiilarge laptop_fontSize9 laptop_px2 laptop_mr2 wide_px4 wide_fontSize7" data-text="News" data-id="news"><div>News <i class="_2DCU1pNSEfcdXke828nLl3 icon-back _1acbDrmILmOdyryPG9dqH0    fontSize12 displayinline-flex  mt3 pl2 laptop_fontSizesmaller"></i></div></button></div><div class="flexccc     displayflex group childrenhide_first positionrelative"><div class="displaynone positionabsolute anchortop w_pxauto minW220 z2 ml0 pointerEventnone" style="top:40px"><div class="bgwhite      displayflex positionrelative shadow3 radiilarge pointerEventauto"><div class="flexcss py3 w_pxauto minW280"><a class="activedisabled activecolororange  fontSize7 alignstart px4 py4 flexrsc minWparent hoverBgwhite-2 hoverColororange" data-link="tv_tv-list" href="/tv/stock-ideas"><span>Stock Ideas</span><div class="ml2 fontWeightnormal lineHeight3 radiiround fontSize12 px3 pt1 flexccc colorwhite bgorange">Popular</div></a><a class="activedisabled activecolororange  fontSize7 alignstart px4 py4 flexrsc minWparent hoverBgwhite-2 hoverColororange" data-link="tv_tv-list" href="/tv/tipranks-originals"><span>TipRanks Originals</span></a><a class="activedisabled activecolororange  fontSize7 alignstart px4 py4 flexrsc minWparent hoverBgwhite-2 hoverColororange" data-link="tv_tv-list" href="/tv/market-updates"><span>Market Updates</span></a><a class="activedisabled activecolororange  fontSize7 alignstart px4 py4 flexrsc minWparent hoverBgwhite-2 hoverColororange" data-link="tv_tv-list" href="/tv/education"><span>Education</span></a></div></div></div><button class="colorgray-5 gHoverBgwhite-2 px3 h_px1 positionrelative borderColorgray fontWeightlight flexcec pb3 fontSize8 bginherit br1_solid brColortransparent bl1_solid blColortransparent radiilarge laptop_fontSize9 laptop_px2 laptop_mr2 wide_px4 wide_fontSize7" data-text="TV" data-id="tv"><div>TV <i class="_2DCU1pNSEfcdXke828nLl3 icon-back _1acbDrmILmOdyryPG9dqH0    fontSize12 displayinline-flex  mt3 pl2 laptop_fontSizesmaller"></i></div></button></div><div class="flexccc     displayflex group childrenhide_first positionrelative"><div class="displaynone positionabsolute anchortop w_pxauto minW220 z2 ml0 pointerEventnone" style="top:40px"><div class="bgwhite      displayflex positionrelative shadow3 radiilarge pointerEventauto"><div class="flexcss py3 w_pxauto minW280"><a class="activedisabled activecolororange  fontSize7 alignstart px4 py4 flexrsc minWparent hoverBgwhite-2 hoverColororange" data-link="smart-portfolio_smart-portfolio-overview" href="/smart-portfolio/overview"><span>Portfolio Overview</span></a><a class="activedisabled activecolororange  fontSize7 alignstart px4 py4 flexrsc minWparent hoverBgwhite-2 hoverColororange" data-link="smart-portfolio_smart-portfolio-holdings" href="/smart-portfolio/holdings"><span>My Holdings</span></a><a class="activedisabled activecolororange  fontSize7 alignstart px4 py4 flexrsc minWparent hoverBgwhite-2 hoverColororange" data-link="smart-portfolio_smart-portfolio-performance" href="/smart-portfolio/performance/me"><span>My Performance</span></a><a class="activedisabled activecolororange  fontSize7 alignstart px4 py4 flexrsc minWparent hoverBgwhite-2 hoverColororange" data-link="smart-portfolio_smart-portfolio-analysis-overview" href="/smart-portfolio/analysis/overview"><span>My Portfolio Analysis</span></a><a class="activedisabled activecolororange  fontSize7 alignstart px4 py4 flexrsc minWparent hoverBgwhite-2 hoverColororange" data-link="smart-portfolio_smart-portfolio-insights" href="/smart-portfolio/insights"><span>Crowd Insights</span></a><a class="activedisabled activecolororange  fontSize7 alignstart px4 py4 flexrsc minWparent hoverBgwhite-2 hoverColororange" data-link="smart-portfolio_account-watchlist" href="/account/my-watchlist"><span>My Watchlist</span></a></div></div></div><button class="colorgray-5 gHoverBgwhite-2 px3 h_px1 positionrelative borderColorgray fontWeightlight flexcec pb3 fontSize8 bginherit br1_solid brColortransparent bl1_solid blColortransparent radiilarge laptop_fontSize9 laptop_px2 laptop_mr2 wide_px4 wide_fontSize7" data-text="Smart Portfolio" data-id="smart-portfolio"><div>Smart Portfolio <i class="_2DCU1pNSEfcdXke828nLl3 icon-back _1acbDrmILmOdyryPG9dqH0    fontSize12 displayinline-flex  mt3 pl2 laptop_fontSizesmaller"></i></div></button></div><div class="flexccc     displayflex group childrenhide_first positionrelative"><div class="displaynone positionabsolute anchortop w_pxauto minW220 z2 ml0 pointerEventnone" style="top:40px;right:-250%"><div class="bgwhite      displayflex positionrelative shadow3 radiilarge pointerEventauto"><div class="displayflex py3"><div class="flexc__  p3   displayflex br1_solid borderColorwhite-1"><div class="displayflex"><i class="_2DCU1pNSEfcdXke828nLl3 icon-personal-card    fontSize10 displayinline-flex  pr2 pt2 bgwhite"></i><span class="fontSize7 fontWeightsemibold    pb3">About Us</span></div><div class="flexcssf pb3 w_px7"><a class="fontSize7 alignstart px2 py4 flexrsc w12 hoverColororange hoverBgwhite-2" data-link="More_about" href="/about"><span>About TipRanks</span></a><a class="fontSize7 alignstart px2 py4 flexrsc w12 hoverColororange hoverBgwhite-2" data-link="More_contact" href="/contact"><span>Contact Us</span></a><a class="fontSize7 alignstart px2 py4 flexrsc w12 hoverColororange hoverBgwhite-2" data-link="More_jobs" href="/jobs"><span>Careers</span></a></div></div><div class="flexc__  p3   displayflex br1_solid borderColorwhite-1"><div class="displayflex"><i class="_2DCU1pNSEfcdXke828nLl3 icon-bag-white    fontSize10 displayinline-flex  pr2 pt2 bgwhite"></i><span class="fontSize7 fontWeightsemibold    pb3">Working with TipRanks</span></div><div class="flexcssf pb3 w_px7"><a class="fontSize7 alignstart px2 py4 flexrsc w12 hoverColororange hoverBgwhite-2" data-link="More_enterprise" href="https://enterprise.tipranks.com/"><span>Enterprise Solutions</span></a><a class="fontSize7 alignstart px2 py4 flexrsc w12 hoverColororange hoverBgwhite-2" data-link="More_enterprise-trading-platforms" href="https://enterprise.tipranks.com/trading-platforms"><span>Tools for Trading Platforms</span></a><a class="fontSize7 alignstart px2 py4 flexrsc w12 hoverColororange hoverBgwhite-2" data-link="More_enterprise-hedge-funds" href="https://enterprise.tipranks.com/hedge-funds/discretionary-funds"><span>Data for Hedge Funds</span></a><a class="fontSize7 alignstart px2 py4 flexrsc w12 hoverColororange hoverBgwhite-2" data-link="More_enterprise-academic-research" href="https://enterprise.tipranks.com/academic-research"><span>Data for Academic Research</span></a><a class="fontSize7 alignstart px2 py4 flexrsc w12 hoverColororange hoverBgwhite-2" data-link="More_affiliate" href="/lp/affiliate"><span>Become an Affiliate</span></a></div></div><div class="flexc__  p3   displayflex br1_solid borderColorwhite-1"><div class="displayflex"><span class="fontSize7 fontWeightsemibold    pb3">Follow Us</span></div><div class="flexcbc py4 minW80"><a class="flexrcc px4 py3" data-link="youtube-tipranks" rel="noreferrer nofollow" target="_blank" href="https://www.youtube.com/channel/UCGNXpSXu1WdSbq5Wr-29ohA"><img class="w_pxsmall filtergray hoverFilternone" src="https://tr-frontend-cdn.azureedge.net/static/v1/static/images/logo/youtube/logo.svg" loading="lazy" alt=""/></a><a class="flexrcc px4 py3" data-link="twitter-tipranks" rel="noreferrer nofollow" target="_blank" href="https://twitter.com/tipranks"><img class="w_pxsmall filtergray hoverFilternone" src="https://tr-frontend-cdn.azureedge.net/static/v1/static/images/logo/twitter/small.svg" loading="lazy" alt=""/></a><a class="flexrcc px4 py3" data-link="stocktwits-tipranks" rel="noreferrer nofollow" target="_blank" href="https://stocktwits.com/tipranks"><img class="w_pxsmall filtergray hoverFilternone" src="https://tr-frontend-cdn.azureedge.net/static/v1/static/images/logo/stocktwits/stocktwits.svg" loading="lazy" alt=""/></a><a class="flexrcc px4 py3" data-link="facebook-tipranks" rel="noreferrer nofollow" target="_blank" href="https://facebook.com/tipranks"><img class="w_pxsmall filtergray hoverFilternone" src="https://tr-frontend-cdn.azureedge.net/static/v1/static/images/logo/facebook/small.svg" loading="lazy" alt=""/></a><a class="flexrcc px4 py3" data-link="instagram-tipranks" rel="noreferrer nofollow" target="_blank" href="https://www.instagram.com/tipranks_for_investors/"><img class="w_pxsmall filtergray hoverFilternone" src="https://tr-frontend-cdn.azureedge.net/static/v1/static/images/logo/instagram/instagram.svg" loading="lazy" alt=""/></a><a class="flexrcc px4 py3" data-link="linkedin-tipranks" rel="noreferrer nofollow" target="_blank" href="http://linkedin.com/company/2858966"><img class="w_pxsmall filtergray hoverFilternone" src="https://tr-frontend-cdn.azureedge.net/static/v1/static/images/logo/linkedin/small.svg" loading="lazy" alt=""/></a></div></div></div></div></div><button class="colorgray-5 gHoverBgwhite-2 px3 h_px1 positionrelative borderColorgray fontWeightlight flexcec pb3 fontSize8 bginherit br1_solid brColortransparent bl1_solid blColortransparent radiilarge laptop_fontSize9 laptop_px2 laptop_mr2 wide_px4 wide_fontSize7" data-text="More" data-id="More"><div>More <i class="_2DCU1pNSEfcdXke828nLl3 icon-back _1acbDrmILmOdyryPG9dqH0    fontSize12 displayinline-flex  mt3 pl2 laptop_fontSizesmaller"></i></div></button></div><div class="flexccc     displayflex group childrenhide_first positionrelative"><div class="displaynone positionabsolute anchortop w_pxauto minW220 z2 ml0 pointerEventnone" style="top:40px"><div class="bgwhite      displayflex positionrelative shadow3 radiilarge pointerEventauto"></div></div><button class="colorgray-5 gHoverBgwhite-2 px3 h_px1 positionrelative borderColorgray fontWeightlight flexcec pb3 fontSize8 bginherit br1_solid brColortransparent bl1_solid blColortransparent radiilarge laptop_fontSize9 laptop_px2 laptop_mr2 wide_px4 wide_fontSize7" data-text="Plans" data-id="Plans"><div>Plans <i class="_2DCU1pNSEfcdXke828nLl3 icon-null _1acbDrmILmOdyryPG9dqH0    fontSize12 displayinline-flex  mt3 pl2 laptop_fontSizesmaller"></i></div></button></div></div></div></div></div></div></div><div class="flexrec     displayflex"><div class="displayflex positionrelative"><div class="kvfE36xNmN1Z7lx3Osmi9 _1AKrVTZdW08NqXI53Z5lNN        displayflex"><div class="loader"></div></div></div><button class="colorgray-3 displaynone ipadpro_displayflex fontSize6 flexccc w_pxsmall50"><i class="_2DCU1pNSEfcdXke828nLl3 icon-hamburger _1cKWBaaBvJKlieJe9Y948W     displayinline-flex"></i></button></div></div></div></div><div class="bgwhite      displaynone ipadpro_displayflex ipadpro_h_pxsmall60 mobile_h_pxsmall50 shadow1 positionfixed anchorbottom w_pxscreen fontSize8 bt1_solid borderColorgray fontWeightsemibold whiteSpacenowrap z2 colorblack-5 animationgoUp" id="footerMobileMenu"><div class="flexrbs w12 maxW480 mxauto"><a class="mobile_fontSize10 h12 flexccc activebb3solid w3 pt3 pb1 active colororange pb2" data-link="news" href="/news"><i class="_2DCU1pNSEfcdXke828nLl3 icon-newsPaper    fontSize5small displayinline-flex  mb1"></i><span>News</span></a><a class="mobile_fontSize10 h12 flexccc activebb3solid w3 pt3 pb1" data-link="smart-portfolio" href="/smart-portfolio"><i class="_2DCU1pNSEfcdXke828nLl3 icon-tvChart    fontSize5small displayinline-flex  mb1"></i><span>Smart Portfolio</span></a><a class="mobile_fontSize10 h12 flexccc activebb3solid w3 pt3 pb1" data-link="tv" href="/tv"><i class="_2DCU1pNSEfcdXke828nLl3 icon-trtv    fontSize5small displayinline-flex  mb1"></i><span>TV</span></a><a class="mobile_fontSize10 h12 flexccc activebb3solid w3 pt3 pb1" data-link="notification" href="/?_route=notification"><i class="_2DCU1pNSEfcdXke828nLl3 icon-bell    fontSize5small displayinline-flex  mb1"></i><span>Notifications</span></a></div></div><div class="bgwhite-1      displaynone z5 colorblack-5 positionfixed fontSize7small overflowYscroll anchorall animationfromRightToLeft"><div class="flexc__     displayflex" id="mobileSideMenu"><div class="bgwhite-2 flexc__     displayflex"><div class="flexrbs w_px8 ml4 mt4 fontSize6"><div class="flexcss     displayflex"><div class="flexrss     displayflex colorpale mb2"><i class="_2DCU1pNSEfcdXke828nLl3 icon-tools    fontSize9 displayinline-flex"></i><span class="flexrsc displayinline-flex w12 px2 fontSize9">TOOLS</span></div><div class="flexc__ w12"><div class="flexrss     displayflex"><a class="colorblack-1 flexrsc py3 w12" data-link="smart-portfolio-holdings" href="/smart-portfolio/holdings"><i class="_2DCU1pNSEfcdXke828nLl3 icon-fourBars   colorgray-1  displayinline-flex  pr3"></i><span>My Portfolio</span></a></div><div class="flexrss     displayflex"><a class="colorblack-1 flexrsc py3 w12" data-link="account-watchlist" href="/account/my-watchlist"><i class="_2DCU1pNSEfcdXke828nLl3 icon-watchlist   colorgray-1  displayinline-flex  pr3"></i><span>My Watchlist</span></a></div><div class="flexrss     displayflex"><a class="colorblack-1 flexrsc py3 w12" data-link="calendars-earnings" href="/calendars/earnings/"><i class="_2DCU1pNSEfcdXke828nLl3 icon-calendar2   colorgray-1  displayinline-flex  pr3"></i><span>Earnings Calendar</span></a></div><div class="flexrss     displayflex"><a class="colorblack-1 flexrsc py3 w12" data-link="screener-stocks" href="/screener/stocks"><i class="_2DCU1pNSEfcdXke828nLl3 icon-threeModifyBars   colorgray-1  displayinline-flex  pr3"></i><span>Stock Screener</span></a></div><div class="flexrss     displayflex"><a class="colorblack-1 flexrsc py3 w12" data-link="screener-slug" href="/screener/penny-stocks"><i class="_2DCU1pNSEfcdXke828nLl3 icon-coin   colorgray-1  displayinline-flex  pr3"></i><span>Penny Stocks</span></a></div><div class="flexrss     displayflex"><a class="colorblack-1 flexrsc py3 w12" data-link="stocks-top-rated" href="/stocks/top-rated"><i class="_2DCU1pNSEfcdXke828nLl3 icon-star2   colorgray-1  displayinline-flex  pr3"></i><span>Top Stocks</span></a></div><div class="flexrss     displayflex"><a class="colorblack-1 flexrsc py3 w12" data-link="tv" href="/tv"><i class="_2DCU1pNSEfcdXke828nLl3 icon-tvWithBorder   colorgray-1  displayinline-flex  pr3"></i><span>TipRanksTV</span><div class="ml2 fontWeightnormal lineHeight3 radiiround fontSize11 px3 pt1 flexccc colorwhite bgpale-dark">New</div></a></div></div></div><div class="flexcss     displayflex"><div class="flexrss     displayflex colorpale mb2"><i class="_2DCU1pNSEfcdXke828nLl3 icon-threeBars2    fontSize9 displayinline-flex"></i><span class="flexrsc displayinline-flex w12 px2 fontSize9">STOCKS</span></div><div class="flexc__ w12"><div class="flexrss     displayflex"><a class="colorblack-1 flexrsc py3 w12" data-link="stock-forecast" href="/stocks/baba/forecast"><i class="_2DCU1pNSEfcdXke828nLl3 icon-baba   colorgray-1  displayinline-flex  pr3"></i><span>BABA</span></a></div><div class="flexrss     displayflex"><a class="colorblack-1 flexrsc py3 w12" data-link="stock-forecast" href="/stocks/aapl/forecast"><i class="_2DCU1pNSEfcdXke828nLl3 icon-aapl   colorgray-1  displayinline-flex  pr3"></i><span>AAPL</span></a></div><div class="flexrss     displayflex"><a class="colorblack-1 flexrsc py3 w12" data-link="stock-forecast" href="/stocks/nio/forecast"><i class="_2DCU1pNSEfcdXke828nLl3 icon-nio   colorgray-1  displayinline-flex  pr3"></i><span>NIO</span></a></div><div class="flexrss     displayflex"><a class="colorblack-1 flexrsc py3 w12" data-link="stock-forecast" href="/stocks/amzn/forecast"><i class="_2DCU1pNSEfcdXke828nLl3 icon-amzn   colorgray-1  displayinline-flex  pr3"></i><span>AMZN</span></a></div><div class="flexrss     displayflex"><a class="colorblack-1 flexrsc py3 w12" data-link="stock-forecast" href="/stocks/amc/forecast"><i class="_2DCU1pNSEfcdXke828nLl3 icon-amc   colorgray-1  displayinline-flex  pr3"></i><span>AMC</span></a></div><div class="flexrss     displayflex"><a class="colorblack-1 flexrsc py3 w12" data-link="stock-forecast" href="/stocks/tsla/forecast"><i class="_2DCU1pNSEfcdXke828nLl3 icon-tsla   colorgray-1  displayinline-flex  pr3"></i><span>TSLA</span></a></div><div class="flexrss     displayflex"><a class="colorblack-1 flexrsc py3 w12" data-link="stock-forecast" href="/stocks/nvda/forecast"><i class="_2DCU1pNSEfcdXke828nLl3 icon-nvda   colorgray-1  displayinline-flex  pr3"></i><span>NVDA</span></a></div></div></div></div><div class="flexcss     displayflex w_px9 pl4"><div class="mt3 displayflex colorpale mb4"><i class="_2DCU1pNSEfcdXke828nLl3 icon-glass    fontSize11 displayinline-flex  flexrcc"></i><span class="flexrsc displayinline-flex w12 px2 fontSize9">ADVANCED RESEARCH</span></div><div class="flexrss     displayflex mb5"><i class="_2DCU1pNSEfcdXke828nLl3 icon-ribbon2   colorgray-1 fontSize6 displayinline-flex  pr3"></i><a class="flexccs" data-link="go-premium" href="/go-premium?llf=mobile-menu-right-go-premium-link"><span class="fontSize8 fontWeightbold">TipRanks Premium</span><div class="flexcss     displayflex"><span class="fontSize10     pr2 pb1">Invest Like a Pro with Unique Data &amp; Simplifed Tools</span><a class="colorwhite-2 fontSize8 flexrcc bgorange radiiround px3 pt1" data-link="go-premium" href="/go-premium?llf=mobile-menu-right-go-premium-link"><span>Try Now</span></a></div></a></div></div></div><div><div><div class="flexcss     displayflex"><button class="colornull flexrbc px2 h_pxsmall50 bb1_solid displayinline-flex borderColorgray fontWeightbold w12 pl5 fontFamilyregular fontSize6small bgnull bgLight90"><span>Top Stocks</span><i class="_2DCU1pNSEfcdXke828nLl3 icon-arrowDropDown b0GWvn6KT7IK2pC1KlFVl   colorblack-0 fontSize12 displayflex  w_px1 flexccc"></i></button><div class="bgwhite-2  w12    displayflex"><div class="displaynone flexcbc w12"><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrbc py4 directionrow activecolororange w12" data-link="stocks-to-buy" href="/stocks-to-buy"><span>Smart Score Stocks</span></a></div><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrbc py4 directionrow activecolororange w12" data-link="stocks-top-rated" href="/stocks/top-rated"><span>Analysts&#x27; Hot Stocks</span></a></div><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrsc py4 directionrow activecolororange w12" data-link="insiders-hot-stocks" href="/experts/insiders/hot-stocks"><span>Insiders&#x27; Hot Stocks</span><div class="ml2 fontWeightlight lineHeight3 radiimedium px2 pt1 fontSize11 flexrcc colorwhite bgorange">Popular</div></a></div><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrbc py4 directionrow activecolororange w12" data-link="trending-stocks" href="/trending-stocks"><span>Trending Stocks</span></a></div><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrsc py4 directionrow activecolororange w12" data-link="web-traffic-screener" href="/screener/website-traffic/top-websites"><span>Fastest Growing Websites</span><div class="ml2 fontWeightlight lineHeight3 radiimedium px2 pt1 fontSize11 flexrcc colorwhite bgpale-dark">New</div></a></div><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrbc py4 directionrow activecolororange w12" data-link="screener-slug" href="/screener/penny-stocks"><span>Penny Stocks</span></a></div><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrbc py4 directionrow activecolororange w12" data-link="market-overview" href="/stocks"><span>U.S. Markets</span></a></div><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrbc py4 directionrow activecolororange w12" data-link="stocks-on-the-move-screener" href="/tools/most-active-stocks"><span>Market Movers</span></a></div></div></div></div><div class="flexcss     displayflex"><button class="colornull flexrbc px2 h_pxsmall50 bb1_solid displayinline-flex borderColorgray fontWeightbold w12 pl5 fontFamilyregular fontSize6small bgnull bgLight90"><span>Top Experts</span><i class="_2DCU1pNSEfcdXke828nLl3 icon-arrowDropDown b0GWvn6KT7IK2pC1KlFVl   colorblack-0 fontSize12 displayflex  w_px1 flexccc"></i></button><div class="bgwhite-2  w12    displayflex"><div class="displaynone flexcbc w12"><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrbc py4 directionrow activecolororange w12" data-link="top-experts" href="/experts/top"><span>Expert Center</span></a></div><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrbc py4 directionrow activecolororange w12" data-link="my-experts" href="/account/my-experts"><span>My Experts</span></a></div><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrbc py4 directionrow activecolororange w12" data-link="firms-top" href="/firms/top"><span>Top Firms</span></a></div><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrbc py4 directionrow activecolororange w12" data-link="experts-top" href="/experts/analysts/top"><span>Top Wall Street Analysts</span></a></div><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrbc py4 directionrow activecolororange w12" data-link="experts-top" href="/experts/bloggers/top"><span>Top Financial Bloggers</span></a></div><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrsc py4 directionrow activecolororange w12" data-link="experts-top" href="/experts/insiders/top"><span>Top Corporate Insiders</span><div class="ml2 fontWeightlight lineHeight3 radiimedium px2 pt1 fontSize11 flexrcc colorwhite bgorange">Popular</div></a></div><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrbc py4 directionrow activecolororange w12" data-link="experts-top" href="/experts/hedge-funds/top"><span>Top Hedge Fund Managers</span></a></div><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrbc py4 directionrow activecolororange w12" data-link="experts-top" href="/experts/investors/top"><span>Top Individual Investors</span></a></div></div></div></div><div class="flexcss     displayflex"><button class="colornull flexrbc px2 h_pxsmall50 bb1_solid displayinline-flex borderColorgray fontWeightbold w12 pl5 fontFamilyregular fontSize6small bgnull bgLight90"><span>Research Tools</span><i class="_2DCU1pNSEfcdXke828nLl3 icon-arrowDropDown b0GWvn6KT7IK2pC1KlFVl   colorblack-0 fontSize12 displayflex  w_px1 flexccc"></i></button><div class="bgwhite-2  w12    displayflex"><div class="displaynone flexcbc w12"><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrbc py4 directionrow activecolororange w12" data-link="screener-stocks" href="/screener/stocks"><span>Stock Screener</span></a></div><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrbc py4 directionrow activecolororange w12" data-link="compare-stocks" href="/compare-stocks"><span>Stock Comparison</span></a></div><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrsc py4 directionrow activecolororange w12" data-link="dividend-calculator" href="/tools/dividend-calculator"><span>Dividend Calculator</span><div class="ml2 fontWeightlight lineHeight3 radiimedium px2 pt1 fontSize11 flexrcc colorwhite bgorange">Popular</div></a></div><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrsc py4 directionrow activecolororange w12" data-link="dividend-yield-calc" href="/tools/dividend-yield-calculator"><span>Dividend Yield Calculator</span><div class="ml2 fontWeightlight lineHeight3 radiimedium px2 pt1 fontSize11 flexrcc colorwhite bgpale-dark">New</div></a></div><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrbc py4 directionrow activecolororange w12" data-link="stock-ratings" href="/stock-ratings"><span>Daily Stock Ratings</span></a></div><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrbc py4 directionrow activecolororange w12" data-link="inside-trading" href="/inside-trading"><span>Daily Insider Transactions</span></a></div></div></div></div><div class="flexcss     displayflex"><button class="colornull flexrbc px2 h_pxsmall50 bb1_solid displayinline-flex borderColorgray fontWeightbold w12 pl5 fontFamilyregular fontSize6small bgnull bgLight90"><span>Comparisons</span><i class="_2DCU1pNSEfcdXke828nLl3 icon-arrowDropDown b0GWvn6KT7IK2pC1KlFVl   colorblack-0 fontSize12 displayflex  w_px1 flexccc"></i></button><div class="bgwhite-2  w12    displayflex"><div class="displaynone flexcbc w12"><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrbc py4 directionrow activecolororange w12" data-link="compare-stocks" href="/compare-stocks"><span>Stock Comparison</span></a><span class="fontSize10   colorpale  px5 py4">POPULAR COMPARISONS</span></div><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrbc py4 directionrow activecolororange w12" data-link="compare-stocks-slug" href="/compare-stocks/wallstreetbets"><span>WallStreetBets Stocks</span></a></div><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrbc py4 directionrow activecolororange w12" data-link="compare-stocks-slug" href="/compare-stocks/nft"><span>NFT Stocks</span></a></div><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrbc py4 directionrow activecolororange w12" data-link="compare-stocks-slug" href="/compare-stocks/electric-vehicles"><span>EV Stocks</span></a></div><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrbc py4 directionrow activecolororange w12" data-link="compare-stocks-slug" href="/compare-stocks/cryptocurrency"><span>Crypto Stocks</span></a></div><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrbc py4 directionrow activecolororange w12" data-link="compare-stocks-slug" href="/compare-stocks/dividend-stocks"><span>Dividend Stocks</span></a></div></div></div></div><div class="flexcss     displayflex"><button class="colornull flexrbc px2 h_pxsmall50 bb1_solid displayinline-flex borderColorgray fontWeightbold w12 pl5 fontFamilyregular fontSize6small bgnull bgLight90"><span>Smart Portfolio</span><i class="_2DCU1pNSEfcdXke828nLl3 icon-arrowDropDown b0GWvn6KT7IK2pC1KlFVl   colorblack-0 fontSize12 displayflex  w_px1 flexccc"></i></button><div class="bgwhite-2  w12    displayflex"><div class="displaynone flexcbc w12"><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrbc py4 directionrow activecolororange w12" data-link="smart-portfolio-overview" href="/smart-portfolio/overview"><span>Overview</span></a></div><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrbc py4 directionrow activecolororange w12" data-link="smart-portfolio-holdings" href="/smart-portfolio/holdings"><span>My Holdings</span></a></div><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrbc py4 directionrow activecolororange w12" data-link="smart-portfolio-performance" href="/smart-portfolio/performance/me"><span>My Performance</span></a></div><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrbc py4 directionrow activecolororange w12" data-link="smart-portfolio-analysis-overview" href="/smart-portfolio/analysis/overview"><span>My Portfolio Analysis</span></a></div><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrbc py4 directionrow activecolororange w12" data-link="smart-portfolio-insights" href="/smart-portfolio/insights"><span>Crowd Insights</span></a></div></div></div></div><div class="flexcss     displayflex"><button class="colornull flexrbc px2 h_pxsmall50 bb1_solid displayinline-flex borderColorgray fontWeightbold w12 pl5 fontFamilyregular fontSize6small bgnull bgLight90"><span>Calendars</span><i class="_2DCU1pNSEfcdXke828nLl3 icon-arrowDropDown b0GWvn6KT7IK2pC1KlFVl   colorblack-0 fontSize12 displayflex  w_px1 flexccc"></i></button><div class="bgwhite-2  w12    displayflex"><div class="displaynone flexcbc w12"><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrbc py4 directionrow activecolororange w12" data-link="calendars-earnings" href="/calendars/earnings/"><span>Earnings Calendar</span></a></div><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrbc py4 directionrow activecolororange w12" data-link="calendars-dividends" href="/calendars/dividends/"><span>Dividend Calendar</span></a></div><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrsc py4 directionrow activecolororange w12" data-link="calendars-economic" href="/calendars/economic"><span>Economic Calendar</span><div class="ml2 fontWeightlight lineHeight3 radiimedium px2 pt1 fontSize11 flexrcc colorwhite bgpale-dark">New</div></a></div><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrbc py4 directionrow activecolororange w12" data-link="calendars-ipo-pricing" href="/calendars/ipo/"><span>IPO Calendar</span></a></div><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrbc py4 directionrow activecolororange w12" data-link="calendars-market-holidays" href="/calendars/market-holidays/"><span>Stock Market Holidays</span></a></div></div></div></div><div class="flexcss     displayflex"><button class="colornull flexrbc px2 h_pxsmall50 bb1_solid displayinline-flex borderColorgray fontWeightbold w12 pl5 fontFamilyregular fontSize6small bgnull bgLight90"><span>News</span><i class="_2DCU1pNSEfcdXke828nLl3 icon-arrowDropDown b0GWvn6KT7IK2pC1KlFVl   colorblack-0 fontSize12 displayflex  w_px1 flexccc"></i></button><div class="bgwhite-2  w12    displayflex"><div class="displaynone flexcbc w12"><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrbc py4 directionrow activecolororange w12" data-link="news" href="/news"><span>Latest</span></a></div><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrsc py4 directionrow activecolororange w12" data-link="news-category-article" href="/news/category/article"><span>Ideas &amp; Insights</span><div class="ml2 fontWeightlight lineHeight3 radiimedium px2 pt1 fontSize11 flexrcc colorwhite bgorange">Popular</div></a></div><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrbc py4 directionrow activecolororange w12" data-link="news-topic" href="/news/topic/dividend-stocks"><span>Dividend Stocks News</span></a></div><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrbc py4 directionrow activecolororange w12" data-link="news-topic" href="/news/topic/penny-stocks"><span>Penny Stocks News</span></a></div><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrbc py4 directionrow activecolororange w12" data-link="news-topic" href="/news/topic/faang"><span>FAANG Stocks News</span></a></div><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrbc py4 directionrow activecolororange w12" data-link="news-category-labs" href="/news/category/labs"><span>TipRanks Labs</span></a></div><div class="flexc__     displayflex"><a class="fontSize6small px5 flexrbc py4 directionrow activecolororange w12" data-link="news-topic" href="/news/topic/crypto-stocks"><span>Crypto Stocks</span></a></div></div></div></div><div class="flexcss     displayflex"><button class="colornull flexrbc px2 h_pxsmall50 bb1_solid displayinline-flex borderColorgray fontWeightbold w12 pl5 fontFamilyregular fontSize6small bgnull bgLight90"><span>About Us</span><i class="_2DCU1pNSEfcdXke828nLl3 icon-arrowDropDown b0GWvn6KT7IK2pC1KlFVl   colorblack-0 fontSize12 displayflex  w_px1 flexccc"></i></button><div class="bgwhite-2  w12    displayflex"><div class="displaynone flexrbcf w12"><div class="flexc__ w8    displayflex"><a class="fontSize6small px5 py4 flexrsc activecolororange w12" data-link="about" href="/about"><span>About TipRanks</span></a></div><div class="flexc_e w4    displayflex"><a class="fontSize6small px5 py4 flexrsc activecolororange w12" data-link="twitter-tipranks" rel="noreferrer nofollow" target="_blank" href="https://twitter.com/tipranks"><i class="_2DCU1pNSEfcdXke828nLl3 icon-twitter   colorgray-1 fontSize6 displayinline-flex"></i><span></span></a></div><div class="flexc__ w8    displayflex"><a class="fontSize6small px5 py4 flexrsc activecolororange w12" data-link="enterprise" href="https://enterprise.tipranks.com/"><span>For Business</span></a></div><div class="flexc_e w4    displayflex"><a class="fontSize6small px5 py4 flexrsc activecolororange w12" data-link="youtube-tipranks" rel="noreferrer nofollow" target="_blank" href="https://www.youtube.com/channel/UCGNXpSXu1WdSbq5Wr-29ohA"><i class="_2DCU1pNSEfcdXke828nLl3 icon-youtube   colorgray-1 fontSize8 displayinline-flex"></i><span></span></a></div><div class="flexc__ w8    displayflex"><a class="fontSize6small px5 py4 flexrsc activecolororange w12" data-link="jobs" href="/jobs"><span>Careers</span></a></div><div class="flexc_e w4    displayflex"><a class="fontSize6small px5 py4 flexrsc activecolororange w12" data-link="stocktwits-tipranks" rel="noreferrer nofollow" target="_blank" href="https://stocktwits.com/tipranks"><i class="_2DCU1pNSEfcdXke828nLl3 icon-stocktwits2   colorgray-1 fontSize6 displayinline-flex"></i><span></span></a></div><div class="flexc__ w8    displayflex"><a class="fontSize6small px5 py4 flexrsc activecolororange w12" data-link="affiliate" href="/lp/affiliate"><span>Become an Affiliate</span></a></div><div class="flexc_e w4    displayflex"><a class="fontSize6small px5 py4 flexrsc activecolororange w12" data-link="facebook-tipranks" rel="noreferrer nofollow" target="_blank" href="https://facebook.com/tipranks"><i class="_2DCU1pNSEfcdXke828nLl3 icon-circleFacebook   colorgray-1 fontSize6 displayinline-flex"></i><span></span></a></div><div class="flexc__ w8    displayflex"><a class="fontSize6small px5 py4 flexrsc activecolororange w12" data-link="tr-education" href="https://education.tipranks.com/"><span>Education Center</span></a></div><div class="flexc_e w4    displayflex"><a class="fontSize6small px5 py4 flexrsc activecolororange w12" data-link="instagram-tipranks" rel="noreferrer nofollow" target="_blank" href="https://www.instagram.com/tipranks_for_investors/"><i class="_2DCU1pNSEfcdXke828nLl3 icon-instagram   colorgray-1 fontSize6 displayinline-flex"></i><span></span></a></div><div class="flexc__ w8    displayflex"><a class="fontSize6small px5 py4 flexrsc activecolororange w12" data-link="reviews" href="/reviews"><span>Reviews</span></a></div><div class="flexc_e w4    displayflex"><a class="fontSize6small px5 py4 flexrsc activecolororange w12" data-link="linkedin-tipranks" rel="noreferrer nofollow" target="_blank" href="http://linkedin.com/company/2858966"><i class="_2DCU1pNSEfcdXke828nLl3 icon-rectLinkedin   colorgray-1 fontSize6 displayinline-flex"></i><span></span></a></div><div class="flexc__ w8    displayflex"><a class="fontSize6small px5 py4 flexrsc activecolororange w12" data-link="contact" href="/contact"><span>Contact Us</span></a></div></div></div></div><a class="flexrbc px2 h_pxsmall50 bb1_solid displayinline-flex borderColorgray fontWeightbold w12 pl5 fontFamilyregular fontSize6small activecolororange" data-link="plans" href="/plans?llf=mobile-menu-right-plans-link"><span>Plans &amp; Pricing</span></a></div></div><div id="mobileMenuBottomBanner" class="px4 py5 w12 radiimedium"></div></div></div><div class="tr-page  w12 pt5 flexccc        displayflex"><script type="application/ld+json">{"@context":"http://schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"/news/why-did-chargepoint-stock-decline-on-tuesday/"},"headline":"Why Did ChargePoint Stock Decline on Tuesday?","datePublished":"2022-06-01T13:59:09.000Z","dateModified":"2022-06-01T13:59:09.000Z","author":{"@type":"Person","name":"Payal Chhawchharia"},"about":[{"@type":"Corporation","tickerSymbol":"CHPT"}],"publisher":{"@type":"Organization","name":"Tipranks","logo":{"@type":"ImageObject","url":"https://tr-frontend-cdn.azureedge.net/static/v1/static/images/logo/tipranks/black-large.png","width":155,"height":45}},"description":"ChargePoint Holdings, Inc. (NYSE: CHPT) disappointed investors after reporting dismal bottom-line results for the first quarter of Fiscal 2023 (ended April 30, 2022). Its loss per share in the quarter\n","image":{"@type":"ImageObject","url":"https://blog.tipranks.com/wp-content/uploads/2022/06/shutterstock_1932544553-750x406.jpg","height":406,"width":750}}</script><div class="flexrcs w12    displayflex fontFamilyregular ipadpro_px2 ipadpro_mt2 ipad_flexc_c mobile_px0"><div class="flexrss w12    displayflex maxW1024 mobile_maxWscreen"><div class="minW80 positionsticky topheader w2 pt8 mt7 pb6 shrink0 ml4 ipadpro_displaynone"><div class="flexc__     displayflex scrollShownone ipad_flexcss ipad_overflowXscroll mobile_ml4"><span class="fontSize6small fontWeightbold    mb3 ipad_displaynone">In this article:</span><div class="flexc__     displayflex maxWparent border1 colorgray radiimedium scrollShownone overflowXscroll overflowYhidden"><div class="w_pxauto ipadpro_flexr__"><div class="flexc__     displayflex ipad_flexr__"><div class="flexrac   px2  displayflex py3 ipadpro_mx3"><div class="flexcc_     displayflex w_px1"><a class="_1BqJeVFwYsZcGIrmOuNw3u UyTSEkPuqMy3HTRrI1n1K  colorlink px3" target="_blank" href="https://www.tipranks.com/stocks/CHPT/stock-analysis"><span class="truncate">CHPT</span></a><div class="_3wap0fGT8Ir5mXXj70b5Vq atom-loading   flexccc     displayflex  mxauto"><div class="_135cbnDbZALKeI43Ru6qv8        displayflex"><svg class="_237Df5Dbk7WNPyo-x9b4YK" viewBox="0 0 50 50" style="width:10px;height:10px"><circle stroke="#1e77f9" class="IAY3ODH4V64Z4wkva-VcY" cx="25" cy="25" r="20" fill="none" stroke-width="5"></circle></svg></div></div></div><div class="_3wap0fGT8Ir5mXXj70b5Vq atom-loading   flexccc     displayflex  mxauto"><div class="_135cbnDbZALKeI43Ru6qv8        displayflex"><svg class="_237Df5Dbk7WNPyo-x9b4YK" viewBox="0 0 50 50" style="width:10px;height:10px"><circle stroke="#1e77f9" class="IAY3ODH4V64Z4wkva-VcY" cx="25" cy="25" r="20" fill="none" stroke-width="5"></circle></svg></div></div><div class="px3  displayflex pt2"><span><button title="Add undefined to your watchlist and get stock ratings alerts, alongside predictions by top financial experts."><i class="_2DCU1pNSEfcdXke828nLl3 icon-circleAdd colorlink _1cKWBaaBvJKlieJe9Y948W    fontSize5 displayinline-flex"></i></button></span></div></div></div></div></div></div><div class="flexrcc     displayflex border1 my4 radiimedium colorgray"><button class="colorblack-6 py3 flexrcc w12 ipad_py0" data-id="share" shareData="[object Object]"><i class="_2DCU1pNSEfcdXke828nLl3 icon-share _1cKWBaaBvJKlieJe9Y948W    fontSize6 displayinline-flex  pr2 mobile_fontSize5small"></i><span class="fontSize6     pl2">Share</span></button></div><div class="displayflex border1 colorgray radiimedium"><button class="colorblack-3 flexrcc fontSize5 w6 pt2 pb1 ipadpro_px5 ipadpro_w_px1 mobile_px2" data-fs="6" title="Increase Font"><span>A+</span></button><div class="displayflex h_pxauto colorgray-0 bl1_solid w_pxauto"></div><button class="colorblack-3 flexrcc pt2 pb1 w6 ipadpro_px5 ipadpro_w_px1 mobile_px2" data-fs="6" title="Decrease Font"><span>A-</span></button></div></div><div class="minW80 px6 displayblock w10 ipadpro_w12 ipadpro_maxWparent ipad_px3 ipad_mr0 mobile_px0 maxW768"><div data-id="tr_banner_widec" class="_2Wr0KDWX4aehq18n-kYX_F  hideOnpremium hideOnultimate  ipadpro_displaynone"><iframe loading="lazy" src="/config/bnr/news/1-widec.html?btype=widec&amp;bscope=news&amp;bid=1" frameBorder="0"></iframe></div><button class="_2DKq_N9RDDp7NkEoGQClbN  colorwhite mlauto transformtranslateY-100p border1 shadow1 borderColororange-light w_pxsmall35 h_px1 flexccc bgorange-light radiibottom-large displaynone ipadpro_displayflex"><i class="_2DCU1pNSEfcdXke828nLl3 icon-magnifyingGlass _1cKWBaaBvJKlieJe9Y948W  mr2   displayinline-flex  mt2"></i></button><div class="flexccs     displayflex"><div class="flexcss     displayflex mobile_mx4"><div class="bgwhite flexrs_     displayflex mb3 fonth6_bold colorlink"><a class="py3 flexrsc active" href="/news"><i class="_2DCU1pNSEfcdXke828nLl3 icon-back    fontSize10 displayinline-flex"></i><span class="ml3">All News</span></a></div><span class="fontSize6 fontWeightbold  colorgray-1  bb2_solid borderColororange-light w_pxauto mobile_fontSize6small">Market News</span><h1 class="fontSize3 fontWeightbolder    maxWparent lineHeight2 my3 ipadpro_fontSize4">Why Did ChargePoint Stock Decline on Tuesday?</h1></div></div><div class="bgwhite-2 flexccs   px5  displayflex py4 radiimedium mobile_mx3 mobile_px4"><span class="fontSize5small fontWeightbold  colorblack-1  pb4">Story Highlights</span><div class="_2z6_JCmzFnjvkf8PhkAfQV"><p><em>ChargePoint seems to be well-positioned to leverage opportunities within the growing electric vehicle industry. Despite this, exposure to near-term headwinds is weighing on the company.</em></p>
</div></div><div class="mt5 displayblock"><div class="displaynone w_px4 ipadpro_maxWparent ipadpro_displayflex ipadpro_directioncReverse ipadpro_mb4 ipadpro_w_pxauto"><div class="flexc__ w12    displayflex scrollShownone ipadpro_flexcss ipadpro_overflowXscroll"><span class="fontSize6small fontWeightbold    mb3 ipadpro_displaynone">In this article:</span><div class="flexc__     displayflex scrollShownone ipad_flexcss ipad_overflowXscroll mobile_ml4"><span class="fontSize6small fontWeightbold    mb3 ipad_displaynone">In this article:</span><div class="flexc__     displayflex maxWparent border1 colorgray radiimedium scrollShownone overflowXscroll overflowYhidden"><div class="w_pxauto ipadpro_flexr__"><div class="flexc__     displayflex ipad_flexr__"><div class="flexrac   px2  displayflex py3 ipadpro_mx3"><div class="flexcc_     displayflex w_px1"><a class="_1BqJeVFwYsZcGIrmOuNw3u UyTSEkPuqMy3HTRrI1n1K  colorlink px3" target="_blank" href="https://www.tipranks.com/stocks/CHPT/stock-analysis"><span class="truncate">CHPT</span></a><div class="_3wap0fGT8Ir5mXXj70b5Vq atom-loading   flexccc     displayflex  mxauto"><div class="_135cbnDbZALKeI43Ru6qv8        displayflex"><svg class="_237Df5Dbk7WNPyo-x9b4YK" viewBox="0 0 50 50" style="width:10px;height:10px"><circle stroke="#1e77f9" class="IAY3ODH4V64Z4wkva-VcY" cx="25" cy="25" r="20" fill="none" stroke-width="5"></circle></svg></div></div></div><div class="_3wap0fGT8Ir5mXXj70b5Vq atom-loading   flexccc     displayflex  mxauto"><div class="_135cbnDbZALKeI43Ru6qv8        displayflex"><svg class="_237Df5Dbk7WNPyo-x9b4YK" viewBox="0 0 50 50" style="width:10px;height:10px"><circle stroke="#1e77f9" class="IAY3ODH4V64Z4wkva-VcY" cx="25" cy="25" r="20" fill="none" stroke-width="5"></circle></svg></div></div><div class="px3  displayflex pt2"><span><button title="Add undefined to your watchlist and get stock ratings alerts, alongside predictions by top financial experts."><i class="_2DCU1pNSEfcdXke828nLl3 icon-circleAdd colorlink _1cKWBaaBvJKlieJe9Y948W    fontSize5 displayinline-flex"></i></button></span></div></div></div></div></div></div></div><div class="flexc__     displayflex ipadpro_flexrbe ipadpro_mb4 mobile_px4"><div class="flexc__     displayflex ipadpro_flexr__ ipadpro_h10 mobile_h8"><div class="flexrcc     displayflex border1 my4 radiimedium colorgray ipadpro_mr3 ipadpro_w_px3 ipadpro_my0 mobile_w_px2 mobile_px6"><button class="colorblack-6 py3 flexrcc w12 ipad_py0" data-id="share" shareData="[object Object]"><i class="_2DCU1pNSEfcdXke828nLl3 icon-share _1cKWBaaBvJKlieJe9Y948W    fontSize6 displayinline-flex  pr2 mobile_fontSize5small"></i><span class="fontSize6     pl2">Share</span></button></div><div class="displayflex border1 colorgray radiimedium"><button class="colorblack-3 flexrcc fontSize5 w6 pt2 pb1 ipadpro_px5 ipadpro_w_px1 mobile_px2" data-fs="6" title="Increase Font"><span>A+</span></button><div class="displayflex h_pxauto colorgray-0 bl1_solid w_pxauto"></div><button class="colorblack-3 flexrcc pt2 pb1 w6 ipadpro_px5 ipadpro_w_px1 mobile_px2" data-fs="6" title="Decrease Font"><span>A-</span></button></div></div></div></div></div><div class="flexcss     displayflex maxWparent"><div class="w12    displayblock"><img class="w12 maxWparent hauto mt3" src="https://blog.tipranks.com/wp-content/uploads/2022/06/shutterstock_1932544553-750x406.jpg" loading="lazy" alt="" width="750" height="406"/><article class="_2R_PgwFP6JivGtFml5dXWQ undefined  fontFamilyregular h_pxauto fontSize6 mobile_mx3">
<p>ChargePoint Holdings, Inc. (<a href="https://www.tipranks.com/stocks/chpt/stock-analysis"><strong>NYSE: CHPT</strong></a>) disappointed investors after reporting dismal bottom-line results for the first quarter of Fiscal 2023 (ended April 30, 2022). Its loss per share in the quarter was 35% wider than the consensus estimate. Meanwhile, revenues exceeded the consensus estimate by 7.8%.</p>



<p>After losing 4.9% during the day, shares of the company, which provides infrastructure for electric vehicles, slipped another 2.7% in the extended trading session on Tuesday.</p>



<h2><strong>Financial Highlights</strong></h2>



<p>In the quarter, ChargePoint posted a loss of $0.27 per share, higher than the consensus loss estimate of $0.20 per share. However, the bottom line was way better than the year-ago tally of a loss of $0.83 per share.</p>



<p>Revenues in the quarter stood at $81.63 million, up from the consensus estimate of $75.7 million and the company’s projection of $72 million to $77 million. On a year-over-year basis, the top line increased 101.5%, driven by a 122.2% jump in networked charging systems, a 63% rise in subscriptions, and a 53.7% surge in other revenues.</p>



<p>The cost of revenues (non-GAAP) in the quarter increased 117.9% year-over-year, while the adjusted gross margin declined 600 basis points (bps) to 17%. Non-GAAP operating expenses increased 78% year-over-year in the quarter. Costs and supply-chain headwinds were spoilsports in the quarter.</p>



<h2><strong>Balance Sheet and Cash Flow</strong></h2>



<p>Exiting the first quarter, ChargePoint’s cash and cash equivalents were $540.6 million, up 71.5% from the end of Fiscal 2022 (ended January 31, 2022). Total liabilities at $622.2 million grew 101.4% quarter-over-quarter.</p>



<p>Net cash used for operating activities was $71 million and capital spending was $3.2 million.</p>



<h2><strong>Projections</strong></h2>



<p>ChargePoint anticipates revenues of $96 million to $106 million in the second quarter of Fiscal 2023 (ending July 31, 2022). This projection reflects a year-over-year jump of 80% at the mid-point.</p>



<p>For Fiscal 2023 (ending January 31, 2023), the company anticipates revenues in the range of $450 million to $500 million, representing year-over-year growth of 96%. Non-GAAP gross margin is expected to be 22% to 26%, and operating expenses are anticipated between $350 million and $370 million.</p>



<h2><strong>Official Comments</strong></h2>



<p>ChargePoint’s President and CEO, Pasquale Romano, said, “Positive first-quarter results, despite expected significant headwinds due to global supply constraints, are a testament to the strength of our business.”</p>



<p>“Our investments in a comprehensive portfolio for all verticals we serve continue to set us apart when customers seek a charging solution,” Romano added.</p>



<h2><strong>Stock Rating</strong></h2>



<p>Overall, the Street is optimistic about the growth prospects of CHPT and has a Strong Buy consensus rating based on nine Buys and three Holds. <a href="https://www.tipranks.com/stocks/chpt/forecast">ChargePoint’s average price target</a> of $23.83 suggests 86.32% upside potential from current levels.</p>



<figure class="wp-block-image size-large"><img src="https://blog.tipranks.com/wp-content/uploads/2022/06/CHPT_2022.png" alt="" class="wp-image-232891" srcset="https://3ts7jc2y8bhe2khfj03ct3q2-wpengine.netdna-ssl.com/wp-content/uploads/2022/06/CHPT_2022.png 802w, https://3ts7jc2y8bhe2khfj03ct3q2-wpengine.netdna-ssl.com/wp-content/uploads/2022/06/CHPT_2022-300x101.png 300w, https://3ts7jc2y8bhe2khfj03ct3q2-wpengine.netdna-ssl.com/wp-content/uploads/2022/06/CHPT_2022-768x259.png 768w" sizes="(max-width: 802px) 100vw, 802px" /></figure>



<p>Shares of ChargePoint have declined 50.7% over the past year.</p>



<h2><strong>Bloggers&#8217; Stance</strong></h2>



<p>According to TipRanks, <a href="https://www.tipranks.com/stocks/chpt/bloggers">financial bloggers are 80% Bullish on CHPT</a>, compared with the sector average of 66%.</p>



<figure class="wp-block-image size-large"><img src="https://blog.tipranks.com/wp-content/uploads/2022/06/CHPT1_2022.png" alt="" class="wp-image-232892" srcset="https://3ts7jc2y8bhe2khfj03ct3q2-wpengine.netdna-ssl.com/wp-content/uploads/2022/06/CHPT1_2022.png 805w, https://3ts7jc2y8bhe2khfj03ct3q2-wpengine.netdna-ssl.com/wp-content/uploads/2022/06/CHPT1_2022-300x61.png 300w, https://3ts7jc2y8bhe2khfj03ct3q2-wpengine.netdna-ssl.com/wp-content/uploads/2022/06/CHPT1_2022-768x157.png 768w" sizes="(max-width: 805px) 100vw, 805px" /></figure>



<h2><strong>Conclusion</strong></h2>



<p>Despite solid top-line drivers, CHPT has to work on its costs to protect its profitability. Further, the growing need and adoption of electric vehicles as well as support from the government are likely to work in favor of companies like ChargePoint. </p>



<p>Read full&nbsp;<a href="https://www.tipranks.com/legal/disclosure-1" target="_blank" rel="noreferrer noopener nofollow">Disclosure</a></p>
</article></div></div><div class="w12    displayflex pt3 maxWparent"><div class="displayflex" id="articlePage"></div></div><div class="bgwhite-2      displayflex my4 radiimedium fontSize6small mobile_flexcs_ mobile_h_pxlarge1 mobile_mx3"><picture><source media="(max-width: 560px)" srcSet="https://tr-frontend-cdn.azureedge.net/static/v1/static/images/content/app-blog/article/app-blog-general_mobile.png"/><source media="(max-width:  868px)" srcSet="https://tr-frontend-cdn.azureedge.net/static/v1/static/images/content/app-blog/article/app-blog-general.png"/><img class="h12 mobile_maxWparent mobile_h_px6" src="https://tr-frontend-cdn.azureedge.net/static/v1/static/images/content/app-blog/article/app-blog-general.png" loading="lazy" alt=""/></picture><div class="flexcac     displayflex"><div class="flexcac     displayflex"><div class="fontSize6 fontWeightbold aligncenter colorblack-1 w10 ipad_fontSize5 mobile_pt3 mobile_w11 mobile_fontSize5small">Tired of arriving late to the Big Returns Party?​</div><div class="py3 flexccc w12"><div class="py3 w10 fontSize7 mobile_w11">Most investors don’t have major gainers like TSLA or NVDA on their radar from the start.</div><div class="py3 w10 fontSize7 mobile_w11">The profusion of opinions on social media and financial blogs makes it impossible to distinguish between real growth potential and pure hype.</div><div class="py3 w10 fontSize7 mobile_w11">​​For the past decade, we have developed and perfected technology designed to help private investors, just like you, find the best opportunities, with the greatest upside potential, in any financial climate.​</div></div></div><a class="colorwhite bgorange-light hoverBgorange radiiround w9 py3 aligncenter fontSize6 fontWeightbold" data-link="go-pro-slug" data-id="article_cta" href="/lp/go-pro/general?llf=news_learn_more"><span>Learn More</span></a></div></div><div class="pt4 pb5 fontSize6 lineHeight2 ipadpro_pb5 mobile_mx3">Full <a class="colorlink" data-link="legal-static-slug" href="/legal/disclaimer"><span>Disclaimer</span></a></div></div></div><div class="pr4 w_px9 shrink0 w4 ipadpro_displaynone"><div class="flexcss w12    displayblock ipadpro_px3 ipadpro_flexrssf"><form class="h_pxsmall50 w12 mb4 ipadpro_displaynone" action="/news/search"><label class="_30lmSDczH8mUvEgvRIJ_ej _1yAKYX9lRItEdYsNuDLYCB _1HvbBMkQ8byfZ1kmMsuD6H      px4  displayflex border1 grow1 h_px1 placeHolderItalic fontSize9 placeHolderColorgray-0 borderColorgray radiiround"><input type="text" autoComplete="" placeholder="News Search" name="s" class="_3tV1b4aDUwZmWLhQEyG-mk  placeHolderColorgray-0 placeHolderItalic"/></label><button class="_2DKq_N9RDDp7NkEoGQClbN  colorwhite mlauto transformtranslateY-100p border1 shadow1 borderColororange-light w_pxsmall35 h_px1 flexccc bgorange-light radiiright" disabled=""><i class="_2DCU1pNSEfcdXke828nLl3 icon-magnifyingGlass _1cKWBaaBvJKlieJe9Y948W  mr2   displayinline-flex  mt2"></i></button></form><div class="minW80 mt2 ipad_flexrssf mobile_pr0"><div class="_1HABim5jz41fqgmk1lBtqo tr-box-ui  flexc__  bgwhite-5  w12    displayflex minHauto z0 mb7 pl4  radiilarge py3   mobile_px3   mobile_w12" data-s="trending"><div class="displayblock mb2"><div class="flexrbb        displayflex mobile_px3"><div class="flexc__     displayflex"><h2 class="fontWeightbold fontSize5small displayinline-block mobile_displayblock mobile_w12">Latest News Feed</h2> </div><div class="flexrcc     displayflex"><div class="flexrcc     displayflex pr3"></div></div></div></div><div class="flexc__ mt3  bgnull      displayflex    positionrelative grow1"><div class="_2U_jOZ-porNw4yDkfEsEvy _1c2E9sfUOHWPNMFDVL6RQc  h_pxtiny4 w12 displaynone"></div><div class="flexr__ overflowXauto  bgwhite      displayflex z2 topheader mobile_shadow1 mobile_positionsticky"></div><div class="w12    displayflex positionrelative grow1" data-sc="trending"><div class="flexc__ h_pxlarge1 overflowYscroll scrollthin scrollShowhover ipadpro_h_pxauto mobile_h_px10 w12"><div class="bgwhite flexc__   px4  displayflex colorblack pt3 radiimedium mr3 border2 borderColorwhite mb3 pb3 mobile_fontSize7"><a class="hoverColororange-light flexcb_" title="WFC | TIPRANKS LABS" href="/news/u-s-senator-sherrod-brown-criticize-wells-fargos-risk-management/"><span class="fontSize8 fontWeightsemibold">U.S. Senator Sherrod Brown Criticizes Wells Fargo’s Risk Management</span><div class="flexrbc w12   mt2 displayflex pt3 bt2_solid borderColorwhite-5"><div class="displayflex"><i class="_2DCU1pNSEfcdXke828nLl3 icon-TRPlus  mr2 colorpurple-2  displaynone"></i><i class="_2DCU1pNSEfcdXke828nLl3 icon-play  mr2 colorblack-6  displaynone"></i></div><div class="flexrsb"><a class="ml2 mb0 fontSize10" href="/news/topic/wfc"><div class="radiiround lineHeight2 px3 pt1 bb1_solid bt1_solid bl1_solid br1_solid colorlink">WFC</div></a></div></div></a></div><div class="bgwhite flexc__   px4  displayflex colorblack pt3 radiimedium mr3 border2 borderColorwhite mb3 pb3 mobile_fontSize7"><a class="hoverColororange-light flexcb_" title="RSI" href="/news/is-rush-streets-top-shareholder-unsure-about-its-success/"><span class="fontSize8 fontWeightsemibold">Is Rush Street’s Top Shareholder Unsure about Its Success?</span><div class="flexrbc w12   mt2 displayflex pt3 bt2_solid borderColorwhite-5"><div class="displayflex"><i class="_2DCU1pNSEfcdXke828nLl3 icon-TRPlus  mr2 colorpurple-2  displaynone"></i><i class="_2DCU1pNSEfcdXke828nLl3 icon-play  mr2 colorblack-6  displaynone"></i></div><div class="flexrsb"><a class="ml2 mb0 fontSize10" href="/news/topic/rsi"><div class="radiiround lineHeight2 px3 pt1 bb1_solid bt1_solid bl1_solid br1_solid colorlink">RSI</div></a></div></div></a></div><div class="bgwhite flexc__   px4  displayflex colorblack pt3 radiimedium mr3 border2 borderColorwhite mb3 pb3 mobile_fontSize7"><a class="hoverColororange-light flexcb_" title="SEV" href="/news/sono-motors-teams-up-with-reefer-on-solar-trailers-street-sees-266-upside/"><span class="fontSize8 fontWeightsemibold">Sono Motors Teams Up with Reefer on Solar Trailers; Street Sees 266% Upside</span><div class="flexrbc w12   mt2 displayflex pt3 bt2_solid borderColorwhite-5"><div class="displayflex"><i class="_2DCU1pNSEfcdXke828nLl3 icon-TRPlus  mr2 colorpurple-2  displaynone"></i><i class="_2DCU1pNSEfcdXke828nLl3 icon-play  mr2 colorblack-6  displaynone"></i></div><div class="flexrsb"><a class="ml2 mb0 fontSize10" href="/news/topic/sev"><div class="radiiround lineHeight2 px3 pt1 bb1_solid bt1_solid bl1_solid br1_solid colorlink">SEV</div></a></div></div></a></div><div class="bgwhite flexc__   px4  displayflex colorblack pt3 radiimedium mr3 border2 borderColorwhite mb3 pb3 mobile_fontSize7"><a class="hoverColororange-light flexcb_" title="FLYW" href="/news/what-does-the-flywire-insider-sell-indicate-for-the-stock/"><span class="fontSize8 fontWeightsemibold">What Does the Flywire Insider Sell Indicate for the Stock?</span><div class="flexrbc w12   mt2 displayflex pt3 bt2_solid borderColorwhite-5"><div class="displayflex"><i class="_2DCU1pNSEfcdXke828nLl3 icon-TRPlus  mr2 colorpurple-2  displaynone"></i><i class="_2DCU1pNSEfcdXke828nLl3 icon-play  mr2 colorblack-6  displaynone"></i></div><div class="flexrsb"><a class="ml2 mb0 fontSize10" href="/news/topic/flyw"><div class="radiiround lineHeight2 px3 pt1 bb1_solid bt1_solid bl1_solid br1_solid colorlink">FLYW</div></a></div></div></a></div><div class="bgwhite flexc__   px4  displayflex colorblack pt3 radiimedium mr3 border2 borderColorwhite mb3 pb3 mobile_fontSize7"><a class="hoverColororange-light flexcb_" title="BRY" href="/news/berry-petroleum-makes-major-buybacks-while-top-insiders-offload-shares/"><span class="fontSize8 fontWeightsemibold">Berry Petroleum Makes Major Buybacks While Top Insiders Offload Shares</span><div class="flexrbc w12   mt2 displayflex pt3 bt2_solid borderColorwhite-5"><div class="displayflex"><i class="_2DCU1pNSEfcdXke828nLl3 icon-TRPlus  mr2 colorpurple-2  displaynone"></i><i class="_2DCU1pNSEfcdXke828nLl3 icon-play  mr2 colorblack-6  displaynone"></i></div><div class="flexrsb"><a class="ml2 mb0 fontSize10" href="/news/topic/bry"><div class="radiiround lineHeight2 px3 pt1 bb1_solid bt1_solid bl1_solid br1_solid colorlink">BRY</div></a></div></div></a></div><div class="bgwhite flexc__   px4  displayflex colorblack pt3 radiimedium mr3 border2 borderColorwhite mb3 pb3 mobile_fontSize7"><a class="hoverColororange-light flexcb_" title="CRM | CVI | MANU | SPGI | VSCO | PRE-MARKET BREAKDOWNS" href="/news/these-stocks-are-the-biggest-pre-market-movers-on-wednesday-19/"><span class="fontSize8 fontWeightsemibold">These Stocks are the Biggest Pre-Market Movers on Wednesday</span><div class="flexrbc w12   mt2 displayflex pt3 bt2_solid borderColorwhite-5"><div class="displayflex"><i class="_2DCU1pNSEfcdXke828nLl3 icon-TRPlus  mr2 colorpurple-2  displaynone"></i><i class="_2DCU1pNSEfcdXke828nLl3 icon-play  mr2 colorblack-6  displaynone"></i></div><div class="flexrsb"><a class="ml2 mb0 fontSize10" href="/news/topic/crm"><div class="radiiround lineHeight2 px3 pt1 bb1_solid bt1_solid bl1_solid br1_solid colorlink">CRM</div></a><a class="ml2 mb0 fontSize10" href="/news/topic/cvi"><div class="radiiround lineHeight2 px3 pt1 bb1_solid bt1_solid bl1_solid br1_solid colorlink">CVI</div></a></div></div></a></div><div class="bgwhite flexc__   px4  displayflex colorblack pt3 radiimedium mr3 border2 borderColorwhite mb3 pb3 mobile_fontSize7"><a class="hoverColororange-light flexcb_" title="TSLA" href="/news/musks-no-more-remote-work-mail-does-rounds-on-twitter/"><span class="fontSize8 fontWeightsemibold">Musk’s “No More Remote Work” Email Making Rounds on Twitter</span><div class="flexrbc w12   mt2 displayflex pt3 bt2_solid borderColorwhite-5"><div class="displayflex"><i class="_2DCU1pNSEfcdXke828nLl3 icon-TRPlus  mr2 colorpurple-2  displaynone"></i><i class="_2DCU1pNSEfcdXke828nLl3 icon-play  mr2 colorblack-6  displaynone"></i></div><div class="flexrsb"><a class="ml2 mb0 fontSize10" href="/news/topic/tsla"><div class="radiiround lineHeight2 px3 pt1 bb1_solid bt1_solid bl1_solid br1_solid colorlink">TSLA</div></a></div></div></a></div><div class="bgwhite flexc__   px4  displayflex colorblack pt3 radiimedium mr3 border2 borderColorwhite mb3 pb3 mobile_fontSize7"><a class="hoverColororange-light flexcb_" title="GB:GSK" href="/news/gsk-to-acquire-affinivax-for-3-3b-to-boost-its-vaccines-roster/"><span class="fontSize8 fontWeightsemibold">GSK to Boost Its Vaccines Roster Through Acquisition</span><div class="flexrbc w12   mt2 displayflex pt3 bt2_solid borderColorwhite-5"><div class="displayflex"><i class="_2DCU1pNSEfcdXke828nLl3 icon-TRPlus  mr2 colorpurple-2  displaynone"></i><i class="_2DCU1pNSEfcdXke828nLl3 icon-play  mr2 colorblack-6  displaynone"></i></div><div class="flexrsb"><a class="ml2 mb0 fontSize10" href="/news/topic/gbgsk"><div class="radiiround lineHeight2 px3 pt1 bb1_solid bt1_solid bl1_solid br1_solid colorlink">GB:GSK</div></a></div></div></a></div><div class="bgwhite flexc__   px4  displayflex colorblack pt3 radiimedium mr3 border2 borderColorwhite mb0 pb2 mobile_fontSize7 bbnull"><a class="hoverColororange-light flexcb_" title="HOOD | TIPRANKS LABS" href="/news/robinhood-agrees-to-settle-with-upset-customers/"><span class="fontSize8 fontWeightsemibold">Robinhood Agrees to Settle With Upset Customers</span><div class="flexrbc w12   mt2 displayflex pt3 bt2_solid borderColorwhite-5"><div class="displayflex"><i class="_2DCU1pNSEfcdXke828nLl3 icon-TRPlus  mr2 colorpurple-2  displaynone"></i><i class="_2DCU1pNSEfcdXke828nLl3 icon-play  mr2 colorblack-6  displaynone"></i></div><div class="flexrsb"><a class="ml2 mb0 fontSize10" href="/news/topic/hood"><div class="radiiround lineHeight2 px3 pt1 bb1_solid bt1_solid bl1_solid br1_solid colorlink">HOOD</div></a></div></div></a></div></div></div></div></div></div></div></div></div><div class="bgwhite-2 flexrcs w12    displayflex fontFamilyregular ipadpro_px2 ipadpro_mt2 ipad_flexc_c mobile_px0"><div class="displayblock visibilityhidden positionsticky topheader  pt8 mt7 pb6 shrink0 ml4 ipadpro_displaynone"><div class="flexc__     displayflex scrollShownone ipad_flexcss ipad_overflowXscroll mobile_ml4"><span class="fontSize6small fontWeightbold    mb3 ipad_displaynone">In this article:</span><div class="flexc__     displayflex maxWparent border1 colorgray radiimedium scrollShownone overflowXscroll overflowYhidden"><div class="w_pxauto ipadpro_flexr__"><div class="flexc__     displayflex ipad_flexr__"><div class="flexrac   px2  displayflex py3 ipadpro_mx3"><div class="flexcc_     displayflex w_px1"><a class="_1BqJeVFwYsZcGIrmOuNw3u UyTSEkPuqMy3HTRrI1n1K  colorlink px3" target="_blank" href="https://www.tipranks.com/stocks/CHPT/stock-analysis"><span class="truncate">CHPT</span></a><div class="_3wap0fGT8Ir5mXXj70b5Vq atom-loading   flexccc     displayflex  mxauto"><div class="_135cbnDbZALKeI43Ru6qv8        displayflex"><svg class="_237Df5Dbk7WNPyo-x9b4YK" viewBox="0 0 50 50" style="width:10px;height:10px"><circle stroke="#1e77f9" class="IAY3ODH4V64Z4wkva-VcY" cx="25" cy="25" r="20" fill="none" stroke-width="5"></circle></svg></div></div></div><div class="_3wap0fGT8Ir5mXXj70b5Vq atom-loading   flexccc     displayflex  mxauto"><div class="_135cbnDbZALKeI43Ru6qv8        displayflex"><svg class="_237Df5Dbk7WNPyo-x9b4YK" viewBox="0 0 50 50" style="width:10px;height:10px"><circle stroke="#1e77f9" class="IAY3ODH4V64Z4wkva-VcY" cx="25" cy="25" r="20" fill="none" stroke-width="5"></circle></svg></div></div><div class="px3  displayflex pt2"><span><button title="Add undefined to your watchlist and get stock ratings alerts, alongside predictions by top financial experts."><i class="_2DCU1pNSEfcdXke828nLl3 icon-circleAdd colorlink _1cKWBaaBvJKlieJe9Y948W    fontSize5 displayinline-flex"></i></button></span></div></div></div></div></div></div><div class="flexrcc     displayflex border1 my4 radiimedium colorgray"><button class="colorblack-6 py3 flexrcc w12 ipad_py0" data-id="share" shareData="[object Object]"><i class="_2DCU1pNSEfcdXke828nLl3 icon-share _1cKWBaaBvJKlieJe9Y948W    fontSize6 displayinline-flex  pr2 mobile_fontSize5small"></i><span class="fontSize6     pl2">Share</span></button></div><div class="displayflex border1 colorgray radiimedium"><button class="colorblack-3 flexrcc fontSize5 w6 pt2 pb1 ipadpro_px5 ipadpro_w_px1 mobile_px2" data-fs="6" title="Increase Font"><span>A+</span></button><div class="displayflex h_pxauto colorgray-0 bl1_solid w_pxauto"></div><button class="colorblack-3 flexrcc pt2 pb1 w6 ipadpro_px5 ipadpro_w_px1 mobile_px2" data-fs="6" title="Decrease Font"><span>A-</span></button></div></div><div class="w10  px6  displayblock minW80 ipadpro_w12 ipadpro_maxWparent ipad_px3 ipad_mr0 mobile_px0 maxW768"></div><div class="visibilityhidden displayblock h_px1 pr4 w_px9 shrink0 w4 ipadpro_displaynone"><div class="flexcss w12    displayblock ipadpro_px3 ipadpro_flexrssf"><form class="h_pxsmall50 w12 mb4 ipadpro_displaynone" action="/news/search"><label class="_30lmSDczH8mUvEgvRIJ_ej _1yAKYX9lRItEdYsNuDLYCB _1HvbBMkQ8byfZ1kmMsuD6H      px4  displayflex border1 grow1 h_px1 placeHolderItalic fontSize9 placeHolderColorgray-0 borderColorgray radiiround"><input type="text" autoComplete="" placeholder="News Search" name="s" class="_3tV1b4aDUwZmWLhQEyG-mk  placeHolderColorgray-0 placeHolderItalic"/></label><button class="_2DKq_N9RDDp7NkEoGQClbN  colorwhite mlauto transformtranslateY-100p border1 shadow1 borderColororange-light w_pxsmall35 h_px1 flexccc bgorange-light radiiright" disabled=""><i class="_2DCU1pNSEfcdXke828nLl3 icon-magnifyingGlass _1cKWBaaBvJKlieJe9Y948W  mr2   displayinline-flex  mt2"></i></button></form><div class="minW80 mt2 ipad_flexrssf mobile_pr0"><div class="_1HABim5jz41fqgmk1lBtqo tr-box-ui  flexc__  bgwhite-5  w12    displayflex minHauto z0 mb7 pl4  radiilarge py3   mobile_px3   mobile_w12" data-s="trending"><div class="displayblock mb2"><div class="flexrbb        displayflex mobile_px3"><div class="flexc__     displayflex"><h2 class="fontWeightbold fontSize5small displayinline-block mobile_displayblock mobile_w12">Latest News Feed</h2> </div><div class="flexrcc     displayflex"><div class="flexrcc     displayflex pr3"></div></div></div></div><div class="flexc__ mt3  bgnull      displayflex    positionrelative grow1"><div class="_2U_jOZ-porNw4yDkfEsEvy _1c2E9sfUOHWPNMFDVL6RQc  h_pxtiny4 w12 displaynone"></div><div class="flexr__ overflowXauto  bgwhite      displayflex z2 topheader mobile_shadow1 mobile_positionsticky"></div><div class="w12    displayflex positionrelative grow1" data-sc="trending"><div class="flexc__ h_pxlarge1 overflowYscroll scrollthin scrollShowhover ipadpro_h_pxauto mobile_h_px10 w12"><div class="bgwhite flexc__   px4  displayflex colorblack pt3 radiimedium mr3 border2 borderColorwhite mb3 pb3 mobile_fontSize7"><a class="hoverColororange-light flexcb_" title="WFC | TIPRANKS LABS" href="/news/u-s-senator-sherrod-brown-criticize-wells-fargos-risk-management/"><span class="fontSize8 fontWeightsemibold">U.S. Senator Sherrod Brown Criticizes Wells Fargo’s Risk Management</span><div class="flexrbc w12   mt2 displayflex pt3 bt2_solid borderColorwhite-5"><div class="displayflex"><i class="_2DCU1pNSEfcdXke828nLl3 icon-TRPlus  mr2 colorpurple-2  displaynone"></i><i class="_2DCU1pNSEfcdXke828nLl3 icon-play  mr2 colorblack-6  displaynone"></i></div><div class="flexrsb"><a class="ml2 mb0 fontSize10" href="/news/topic/wfc"><div class="radiiround lineHeight2 px3 pt1 bb1_solid bt1_solid bl1_solid br1_solid colorlink">WFC</div></a></div></div></a></div><div class="bgwhite flexc__   px4  displayflex colorblack pt3 radiimedium mr3 border2 borderColorwhite mb3 pb3 mobile_fontSize7"><a class="hoverColororange-light flexcb_" title="RSI" href="/news/is-rush-streets-top-shareholder-unsure-about-its-success/"><span class="fontSize8 fontWeightsemibold">Is Rush Street’s Top Shareholder Unsure about Its Success?</span><div class="flexrbc w12   mt2 displayflex pt3 bt2_solid borderColorwhite-5"><div class="displayflex"><i class="_2DCU1pNSEfcdXke828nLl3 icon-TRPlus  mr2 colorpurple-2  displaynone"></i><i class="_2DCU1pNSEfcdXke828nLl3 icon-play  mr2 colorblack-6  displaynone"></i></div><div class="flexrsb"><a class="ml2 mb0 fontSize10" href="/news/topic/rsi"><div class="radiiround lineHeight2 px3 pt1 bb1_solid bt1_solid bl1_solid br1_solid colorlink">RSI</div></a></div></div></a></div><div class="bgwhite flexc__   px4  displayflex colorblack pt3 radiimedium mr3 border2 borderColorwhite mb3 pb3 mobile_fontSize7"><a class="hoverColororange-light flexcb_" title="SEV" href="/news/sono-motors-teams-up-with-reefer-on-solar-trailers-street-sees-266-upside/"><span class="fontSize8 fontWeightsemibold">Sono Motors Teams Up with Reefer on Solar Trailers; Street Sees 266% Upside</span><div class="flexrbc w12   mt2 displayflex pt3 bt2_solid borderColorwhite-5"><div class="displayflex"><i class="_2DCU1pNSEfcdXke828nLl3 icon-TRPlus  mr2 colorpurple-2  displaynone"></i><i class="_2DCU1pNSEfcdXke828nLl3 icon-play  mr2 colorblack-6  displaynone"></i></div><div class="flexrsb"><a class="ml2 mb0 fontSize10" href="/news/topic/sev"><div class="radiiround lineHeight2 px3 pt1 bb1_solid bt1_solid bl1_solid br1_solid colorlink">SEV</div></a></div></div></a></div><div class="bgwhite flexc__   px4  displayflex colorblack pt3 radiimedium mr3 border2 borderColorwhite mb3 pb3 mobile_fontSize7"><a class="hoverColororange-light flexcb_" title="FLYW" href="/news/what-does-the-flywire-insider-sell-indicate-for-the-stock/"><span class="fontSize8 fontWeightsemibold">What Does the Flywire Insider Sell Indicate for the Stock?</span><div class="flexrbc w12   mt2 displayflex pt3 bt2_solid borderColorwhite-5"><div class="displayflex"><i class="_2DCU1pNSEfcdXke828nLl3 icon-TRPlus  mr2 colorpurple-2  displaynone"></i><i class="_2DCU1pNSEfcdXke828nLl3 icon-play  mr2 colorblack-6  displaynone"></i></div><div class="flexrsb"><a class="ml2 mb0 fontSize10" href="/news/topic/flyw"><div class="radiiround lineHeight2 px3 pt1 bb1_solid bt1_solid bl1_solid br1_solid colorlink">FLYW</div></a></div></div></a></div><div class="bgwhite flexc__   px4  displayflex colorblack pt3 radiimedium mr3 border2 borderColorwhite mb3 pb3 mobile_fontSize7"><a class="hoverColororange-light flexcb_" title="BRY" href="/news/berry-petroleum-makes-major-buybacks-while-top-insiders-offload-shares/"><span class="fontSize8 fontWeightsemibold">Berry Petroleum Makes Major Buybacks While Top Insiders Offload Shares</span><div class="flexrbc w12   mt2 displayflex pt3 bt2_solid borderColorwhite-5"><div class="displayflex"><i class="_2DCU1pNSEfcdXke828nLl3 icon-TRPlus  mr2 colorpurple-2  displaynone"></i><i class="_2DCU1pNSEfcdXke828nLl3 icon-play  mr2 colorblack-6  displaynone"></i></div><div class="flexrsb"><a class="ml2 mb0 fontSize10" href="/news/topic/bry"><div class="radiiround lineHeight2 px3 pt1 bb1_solid bt1_solid bl1_solid br1_solid colorlink">BRY</div></a></div></div></a></div><div class="bgwhite flexc__   px4  displayflex colorblack pt3 radiimedium mr3 border2 borderColorwhite mb3 pb3 mobile_fontSize7"><a class="hoverColororange-light flexcb_" title="CRM | CVI | MANU | SPGI | VSCO | PRE-MARKET BREAKDOWNS" href="/news/these-stocks-are-the-biggest-pre-market-movers-on-wednesday-19/"><span class="fontSize8 fontWeightsemibold">These Stocks are the Biggest Pre-Market Movers on Wednesday</span><div class="flexrbc w12   mt2 displayflex pt3 bt2_solid borderColorwhite-5"><div class="displayflex"><i class="_2DCU1pNSEfcdXke828nLl3 icon-TRPlus  mr2 colorpurple-2  displaynone"></i><i class="_2DCU1pNSEfcdXke828nLl3 icon-play  mr2 colorblack-6  displaynone"></i></div><div class="flexrsb"><a class="ml2 mb0 fontSize10" href="/news/topic/crm"><div class="radiiround lineHeight2 px3 pt1 bb1_solid bt1_solid bl1_solid br1_solid colorlink">CRM</div></a><a class="ml2 mb0 fontSize10" href="/news/topic/cvi"><div class="radiiround lineHeight2 px3 pt1 bb1_solid bt1_solid bl1_solid br1_solid colorlink">CVI</div></a></div></div></a></div><div class="bgwhite flexc__   px4  displayflex colorblack pt3 radiimedium mr3 border2 borderColorwhite mb3 pb3 mobile_fontSize7"><a class="hoverColororange-light flexcb_" title="TSLA" href="/news/musks-no-more-remote-work-mail-does-rounds-on-twitter/"><span class="fontSize8 fontWeightsemibold">Musk’s “No More Remote Work” Email Making Rounds on Twitter</span><div class="flexrbc w12   mt2 displayflex pt3 bt2_solid borderColorwhite-5"><div class="displayflex"><i class="_2DCU1pNSEfcdXke828nLl3 icon-TRPlus  mr2 colorpurple-2  displaynone"></i><i class="_2DCU1pNSEfcdXke828nLl3 icon-play  mr2 colorblack-6  displaynone"></i></div><div class="flexrsb"><a class="ml2 mb0 fontSize10" href="/news/topic/tsla"><div class="radiiround lineHeight2 px3 pt1 bb1_solid bt1_solid bl1_solid br1_solid colorlink">TSLA</div></a></div></div></a></div><div class="bgwhite flexc__   px4  displayflex colorblack pt3 radiimedium mr3 border2 borderColorwhite mb3 pb3 mobile_fontSize7"><a class="hoverColororange-light flexcb_" title="GB:GSK" href="/news/gsk-to-acquire-affinivax-for-3-3b-to-boost-its-vaccines-roster/"><span class="fontSize8 fontWeightsemibold">GSK to Boost Its Vaccines Roster Through Acquisition</span><div class="flexrbc w12   mt2 displayflex pt3 bt2_solid borderColorwhite-5"><div class="displayflex"><i class="_2DCU1pNSEfcdXke828nLl3 icon-TRPlus  mr2 colorpurple-2  displaynone"></i><i class="_2DCU1pNSEfcdXke828nLl3 icon-play  mr2 colorblack-6  displaynone"></i></div><div class="flexrsb"><a class="ml2 mb0 fontSize10" href="/news/topic/gbgsk"><div class="radiiround lineHeight2 px3 pt1 bb1_solid bt1_solid bl1_solid br1_solid colorlink">GB:GSK</div></a></div></div></a></div><div class="bgwhite flexc__   px4  displayflex colorblack pt3 radiimedium mr3 border2 borderColorwhite mb0 pb2 mobile_fontSize7 bbnull"><a class="hoverColororange-light flexcb_" title="HOOD | TIPRANKS LABS" href="/news/robinhood-agrees-to-settle-with-upset-customers/"><span class="fontSize8 fontWeightsemibold">Robinhood Agrees to Settle With Upset Customers</span><div class="flexrbc w12   mt2 displayflex pt3 bt2_solid borderColorwhite-5"><div class="displayflex"><i class="_2DCU1pNSEfcdXke828nLl3 icon-TRPlus  mr2 colorpurple-2  displaynone"></i><i class="_2DCU1pNSEfcdXke828nLl3 icon-play  mr2 colorblack-6  displaynone"></i></div><div class="flexrsb"><a class="ml2 mb0 fontSize10" href="/news/topic/hood"><div class="radiiround lineHeight2 px3 pt1 bb1_solid bt1_solid bl1_solid br1_solid colorlink">HOOD</div></a></div></div></a></div></div></div></div></div></div></div></div></div></div></div><div><footer class="bgblack-3 colorgray-0 py0 px0 fontSize7 ipadpro_fontSize7small mobile_fontSize7 lineHeight4" id="tr-footer-app"><div class="maxW1024 mxauto ipadpro_px4 mobile_directioncReverse mobile_flexc__        displayflex py7 mobile_py5"><div class="flexc__     displayflex w_px8 shrink0 pr4 ipad_w_px7 mobile_w12 mobile_mr0 mobile_pr4 mobile_w_pxauto mobile_directioncReverse"><div class="flexcss     displayflex"><div class="flexcss     displayflex mobile_mt5"><img class="mb3" src="https://tr-frontend-cdn.azureedge.net/static/v1/static/images/logo/tipranks/white.svg" loading="lazy" alt="tipranks"/><div class="flexc__     displayflex"><span class="maxWparent">TipRanks is a comprehensive investing tool that allows private investors and day traders to see the measured performance of anyone who provides financial advice.</span><div class="flexc__ w12   mt5 displayflex"><span class="colorwhite mb3 fontWeightsemibold">Find Us on</span><div class="w12"><a class="w2 displayinline-flex" data-link="twitter-tipranks" rel="noreferrer nofollow" target="_blank" href="https://twitter.com/tipranks"><img src="https://tr-frontend-cdn.azureedge.net/static/v1/static/images/logo/twitter/white.png" loading="lazy" alt="twitter"/></a><a class="w2 displayinline-flex" data-link="stocktwits-tipranks" rel="noreferrer nofollow" target="_blank" href="https://stocktwits.com/tipranks"><img src="https://tr-frontend-cdn.azureedge.net/static/v1/static/images/logo/stocktwits/white.png" loading="lazy" alt="stocktwits"/></a><a class="w2 displayinline-flex" data-link="facebook-tipranks" rel="noreferrer nofollow" target="_blank" href="https://facebook.com/tipranks"><img src="https://tr-frontend-cdn.azureedge.net/static/v1/static/images/logo/facebook/white.png" loading="lazy" alt="facebook"/></a><a class="w2 displayinline-flex" data-link="linkedin-tipranks" rel="noreferrer nofollow" target="_blank" href="http://linkedin.com/company/2858966"><img src="https://tr-frontend-cdn.azureedge.net/static/v1/static/images/logo/linkedin/white.png" loading="lazy" alt="linkedin"/></a></div><div class="flexc__    mt6 displayflex"><div class="bgtransparent flexc__   px0  displayflex py0 border0 borderColorgray mobile_mb5 mb4"><span class="colorwhite mb3 fontWeightsemibold       textTransformuppercase">Newsletter Subscription</span><span class="mb3">Enter your email to receive our newsletter</span><form class="flexrsef mt1"><label class="_30lmSDczH8mUvEgvRIJ_ej _1yAKYX9lRItEdYsNuDLYCB _1HvbBMkQ8byfZ1kmMsuD6H  bgwhite    px3  displayflex grow1 border1 h_pxsmall1 borderColorgray placeHolderColorgray-1  mobile_fontSize6 mobile_fontWeightsemibold mobile_h_px1"><input type="email" autoComplete="email" placeholder="Email address" required="" class="_3tV1b4aDUwZmWLhQEyG-mk  placeHolderColorgray-1"/></label><button class="_2DKq_N9RDDp7NkEoGQClbN  colorwhite hoverOpacity80 positionrelative bgorange shadow1 whiteSpacenowrap   px3 h_pxsmall1  shrink0 ml3 fontSize8 lineHeight1 mobile_ml3 mobile_mt3 mobile_h_px1 mobile_px4 mobile_fontWeightbold"><span>SIGN UP</span></button></form></div><div class="flexrb_    mt5 displayflex"><a class="w6 h12 flexrs_" rel="noreferrer nofollow" target="_blank" href="https://apps.apple.com/us/app/id1237516490"><img class="w11" src="https://tr-frontend-cdn.azureedge.net/static/v1/static/images/logo/ios/app_badge.svg" loading="lazy" alt="ios"/></a><a class="w6 flexres" rel="noreferrer nofollow" target="_blank" href="https://play.google.com/store/apps/details?id=com.tipranks.android&amp;hl=iw&amp;gl=US"><img class="w11" src="https://tr-frontend-cdn.azureedge.net/static/v1/static/images/logo/android/app_badge.svg" loading="lazy" alt="android"/></a></div> </div></div></div> </div> </div><div class="flexrb_f mt4 mobile_mt0 mobile_flexc__"><a class="hoverOpacity80 ipadpro_w12 mobile_lineHeight5" data-link="sitemap" href="/site-map"><span>Sitemap</span></a><a class="hoverOpacity80 ipadpro_w12 mobile_lineHeight5" data-link="terms" href="/terms"><span>Terms of Use</span></a><a class="hoverOpacity80 ipadpro_w12 mobile_lineHeight5" data-link="privacypolicy" href="/privacypolicy"><span>Privacy Policy</span></a><a class="hoverOpacity80 ipadpro_w12 mobile_lineHeight5" data-link="faq" href="/faq"><span>FAQ</span></a></div></div><div class="flexcssf grow1 h_px9 mt4 pt3 pl4 ipad_h_pxauto ipad_flexrssf mobile_pl0 mobile_ml0 mobile_flexc__ mobile_maxWparent"><div class="flexc_s     displayflex minW220 ipad_w6  my3 mobile_pl0 mobile_w12 mobile_mt0 mobile_lineHeight5  pl3"><span class="colorwhite mb3 fontWeightsemibold       mobile_displaynone">Research Tools</span><a class="hoverOpacity80 mt2 flexrsc fontWeightnormal mobile_mb0" data-link="stocks-to-buy" href="/stocks-to-buy"><span>Top Smart Score Stocks</span></a><a class="hoverOpacity80 mt2 flexrsc fontWeightnormal mobile_mb0" data-link="trending-stocks" href="/trending-stocks"><span>Trending Stocks</span></a><a class="hoverOpacity80 mt2 flexrsc fontWeightnormal mobile_mb0" data-link="stock-ratings" href="/stock-ratings"><span>Daily Stock Ratings</span></a><a class="hoverOpacity80 mt2 flexrsc fontWeightnormal mobile_mb0" data-link="screener-stocks" href="/screener/stocks"><span>Stock Screener</span></a><a class="hoverOpacity80 mt2 flexrsc fontWeightnormal mobile_mb0" data-link="compare-stocks" href="/compare-stocks"><span>Stock Comparison</span></a><a class="hoverOpacity80 mt2 flexrsc fontWeightnormal mobile_mb0" data-link="stocks-top-rated" href="/stocks/top-rated"><span>Analysts&#x27; Top Stocks</span></a><a class="hoverOpacity80 mt2 flexrsc fontWeightnormal mobile_mb0" data-link="inside-trading" href="/inside-trading"><span>Daily Insider Transactions</span></a><a class="hoverOpacity80 mt2 flexrsc fontWeightnormal mobile_mb0" data-link="insiders-hot-stocks" href="/experts/insiders/hot-stocks"><span>Insiders&#x27; Hot Stocks</span></a><a class="hoverOpacity80 mt2 flexrsc fontWeightnormal mobile_mb0" data-link="top-experts" href="/experts/top"><span>Expert Center</span></a></div><div class="flexc_s     displayflex minW220 ipad_w6 h_px4 my3 mobile_pl0 mobile_w12 mobile_mt0 mobile_lineHeight5  pl3"><span class="colorwhite mb3 fontWeightsemibold       mobile_displaynone">Calendars</span><a class="hoverOpacity80 mt2 flexrsc fontWeightnormal mobile_mb0" data-link="calendars-earnings" href="/calendars/earnings/"><span>Earnings Calendar</span></a><a class="hoverOpacity80 mt2 flexrsc fontWeightnormal mobile_mb0" data-link="calendars-dividends" href="/calendars/dividends/"><span>Dividend Calendar</span></a><a class="hoverOpacity80 mt2 flexrsc fontWeightnormal mobile_mb0" data-link="calendars-ipo-pricing" href="/calendars/ipo/"><span>IPO Calendar</span></a><a class="hoverOpacity80 mt2 flexrsc fontWeightnormal mobile_mb0" data-link="calendars-market-holidays" href="/calendars/market-holidays/"><span>Stock Market Holidays</span></a></div><div class="flexc_s     displayflex minW220 ipad_w6 h_px4 my3 mobile_pl0 mobile_w12 mobile_mt0 mobile_lineHeight5  pl3"><span class="colorwhite mb3 fontWeightsemibold       mobile_displaynone">Education</span><a class="hoverOpacity80 mt2 flexrsc fontWeightnormal mobile_mb0" data-link="glossary" href="/glossary"><span>Glossary</span></a><a class="hoverOpacity80 mt2 flexrsc fontWeightnormal mobile_mb0" data-link="news-category-news" href="/news/category/news"><span>Market News</span></a><a class="hoverOpacity80 mt2 flexrsc fontWeightnormal mobile_mb0" data-link="tr-education" href="https://education.tipranks.com/"><span>Education Center</span></a></div><div class="flexc_s     displayflex minW220 ipad_w6 h_px4 my3 mobile_pl0 mobile_w12 mobile_mt0 mobile_lineHeight5  pl3"><span class="colorwhite mb3 fontWeightsemibold       mobile_displaynone">Plans</span><a class="hoverOpacity80 mt2 flexrsc fontWeightnormal mobile_mb0" data-link="plans" href="/plans?llf=footer-plans"><span>Plans &amp; Pricing</span></a><a class="hoverOpacity80 mt2 flexrsc fontWeightnormal mobile_mb0" data-link="enterprise" href="https://enterprise.tipranks.com/"><span>API for Institutions</span></a><a class="hoverOpacity80 mt2 flexrsc fontWeightnormal mobile_mb0" data-link="quantranks" target="_blank" href="https://quant.tipranks.com/"><span>Build a Quant Strategy</span></a></div><div class="flexc_s     displayflex minW220 ipad_w6 h_px4 my3 mobile_pl0 mobile_w12 mobile_mt0 mobile_lineHeight5  pl3"><span class="colorwhite mb3 fontWeightsemibold       mobile_displaynone">Company</span><a class="hoverOpacity80 mt2 flexrsc fontWeightnormal mobile_mb0" data-link="about" href="/about"><span>About TipRanks</span></a><a class="hoverOpacity80 mt2 flexrsc fontWeightnormal mobile_mb0" data-link="contact" href="/contact"><span>Contact Us</span></a><a class="hoverOpacity80 mt2 flexrsc fontWeightnormal mobile_mb0" data-link="reviews" href="/reviews"><span>Reviews</span></a><a class="hoverOpacity80 mt2 flexrsc fontWeightnormal mobile_mb0" data-link="jobs" href="/jobs"><span>Jobs</span></a></div></div></div><div class="bgwhite      displayflex lineHeight4 fontSize9 fontFamilyarial alignjustify colorgray-2"><div class="maxW1024 mxauto ipadpro_px4 mobile_directioncReverse mobile_flexc__        displayflex py5"><div class="displayblock ipadpro_pb5"><span class="fontWeightbold">Disclaimer: </span><span>The TipRanks Smart Score performance is based on backtested results. Backtested performance is not an indicator of future actual results. The results reflect performance of a strategy not historically offered to investors and does not represent returns that any investor actually attained. Backtested results are calculated by the retroactive application of a model constructed on the basis of historical data and based on assumptions integral to the model which may or may not be testable and are subject to losses. General assumptions include: XYZ firm would have been able to purchase the securities recommended by the model and the markets were sufficiently liquid to permit all trading. Changes in these assumptions may have a material impact on the backtested returns presented. Certain assumptions have been made for modeling purposes and are unlikely to be realized. No representations and warranties are made as to the reasonableness of the assumptions. This information is provided for illustrative purposes only. Backtested performance is developed with the benefit of hindsight and has inherent limitations. Specifically, backtested results do not reflect actual trading or the effect of material economic and market factors on the decision-making process. Since trades have not actually been executed, results may have under- or over-compensated for the impact, if any, of certain market factors, such as lack of liquidity, and may not reflect the impact that certain economic or market factors may have had on the decision-making process. Further, backtesting allows the security selection methodology to be adjusted until past returns are maximized. Actual performance may differ significantly from backtested performance. Backtested results are adjusted to reflect the reinvestment of dividends and other income and, except where otherwise indicated, are presented gross-of fees and do not include the effect of backtested transaction costs, management fees, performance fees or expenses, if applicable. Please note all regulatory considerations regarding the presentation of fees must be taken into account. No cash balance or cash flow is included in the calculation.</span></div></div></div></footer></div></div>
  <script>
    window.payload = 1654092741165
  </script>
          <script>
            window.renderTime = 1654092741165
          </script>
         
         <div id="modal-root"></div><link rel="stylesheet" href="https://tr-frontend-cdn.azureedge.net/blog/__tr__/prod/css/1a8412edc99b0beeb455.styles.css"/><script integrity="sha256-dgyPHS+7ZIVWaTOotraqwdUf8LEQAQNDjxNrebzf2Lg=" nomodule="true" crossorigin="anonymous" src="https://cdnjs.cloudflare.com/ajax/libs/babel-polyfill/7.7.0/polyfill.min.js"></script><script>document.getElementsByTagName("body")[0].classList.remove("tr-loading");
      
      loadFonts();
      (function () {
        window.onpageshow = function(event) {
          if (event.persisted) {
            //temporary solve issue with back-forward cache - https://web.dev/bfcache/
            window.location.reload();
            
            //reset from remove the opacity from the fade page transition bcz SAFARI
            var page=document.getElementsByClassName("tr-page");
            if(page && page[0]){
              page[0].style.opacity = "1";
            }
            setTimeout(function(){
              var page=document.getElementsByClassName("tr-page");
              if(page && page[0]){
                page[0].style.opacity = "1";
              }
            },300);
            
          }
        };
      })();
      (function (jsFiles, gtm) {
     
        window.addEventListener("load", function () {
          try{
            var cookieData=getCookie();
            if(cookieData.GTM_OVERRIDE){
              gtm=cookieData.GTM_OVERRIDE;
            }
          }catch(e){

          }
         

          var  isFastDevice = window.innerWidth > 560;
          var search = parseQuery();
          var GTM_DELAY = '2500';
          var JS_DELAY = '2500';
          var gtmDelay = GTM_DELAY ? parseInt(GTM_DELAY):0;
          var jsDelay = JS_DELAY ? parseInt(JS_DELAY):0;
          var isPayUser = window.__tipranksPlanId__ === "premium" || window.__tipranksPlanId__ === "ultimate";

          if(isPayUser || window.location.pathname === "/f_l_"){
            jsDelay=0;
          }
          if(isPayUser){
            gtmDelay=0;
          }

          if(isFastDevice){
            jsDelay=0;
          }

          gtmDelay = search &&   search.gtmDelay ?parseInt( search.gtmDelay):gtmDelay;
          jsDelay = search &&  search.jsDelay ?parseInt(search.jsDelay):jsDelay;
          
         
         
        

          window.dataLayer = window.dataLayer || [];
          window.dataLayer.push({
            "gtm.start": new Date().getTime(),
            event: "gtm.js"
          }); 
          

       
           setTimeout(function(){
              jsFiles.forEach(function (jsFile) {
                loadScriptTag(jsFile);
              })
           },jsDelay)
           if(window.location.hostname.includes("www")){
            setTimeout(function(){
                var reblaze = "/c3650cdf-216a-4ba2-80b0-9d6c540b105e58d2670b-ea0f-484e-b88c-0e2c1499ec9bd71e4b42-8570-44e3-89b6-845326fa43b6";
                loadScriptTag(reblaze)
              },jsDelay);
           }
           
          var gtmUrl = "//gtm.tipranks.com/gtm.js?id=" + gtm;
            setTimeout(function(){
              loadScriptTag(gtmUrl);
            },gtmDelay)

        });
      })(["https://polyfill.io/v3/polyfill.min.js",
        
        "https://tr-frontend-cdn.azureedge.net/blog/__tr__/prod/js/1a8412edc99b0beeb455.styles.min.js","https://tr-frontend-cdn.azureedge.net/blog/__tr__/prod/js/1a8412edc99b0beeb455.main.min.js"],
        'GTM-WMX37F');</script><noscript>You need to enable JavaScript to run this app.</noscript></body></html>